SERIOUS Leopard BUG: Can't Login Post Install

Discussion in 'macOS' started by rhomsy, Oct 26, 2007.

  1. rhomsy macrumors regular

    Joined:
    Jul 6, 2007
    #1
    I don't know what to do. I installed Leopard over 10.4.10 as an upgrade on my iMac C2D and after the system rebooted into Leopard for the first time, I can't login to the admin account. I just doesn't accept the password anymore! My second non-admin account works, but I'm completely locked out of the admin account! Even worse, I can't reset the password using the utility on the Leopard Boot Disk. The password reset utility doesn't seem to work!

    I really don't know what to do. I didn't backup before the install (I bought a second drive and was planning on backing up with Time Machine after Leopard was installed). I'm locked out of my own computer.

    Can someone help?
     
  2. viggen61 macrumors 6502

    Joined:
    Jul 24, 2002
    Location:
    New Jersey
    #2
    Same here!

    I have the exact same problem.:(

    I can log in as root (System Administrator), and one of my other accounts, but the account that has been my main day-to-day work account (which also happens to be an Admin), I can't get into.

    MBP 15", regular "upgrade" install of Leopard.

    I tried the password reset from the Leopard disk - nothing. Tried using the Users System Pref Pane, also nothing. Remarkably, if I change the "hint" text, THAT DOES WORK. Just that the password won't.:confused:

    A friend of mine mentioned the keychain, and I tried looking at that, but what he's telling me, and what I see are different. He's not on Leopard, so perhaps that app got an upgrade, too.

    UPDATE: Ran FSCK last night from single-user mode (/sbin/fsck -fy) and it reported no problems. This is the first time I've ever had any problems with a Mac OS X upgrade or update. Should have done my G4 (1.2Ghz proc) first!
    This is very strange. I can do System Preferences:Accounts, choose the account I need to change, reset the password, reset the "hint", log out from root, log in as the user I jst changed, and it won't accept the new password. Just gives me the "head shake".
     
  3. zmapper macrumors newbie

    Joined:
    Oct 26, 2007
    #3
    Same problem

    Installed Leopard. After reboot, the only user listed for login is 'other'. When I click on 'other' I can then put in my user name (which has admin privileges), and password, but it isn't accepted. Haven't found any workaround yet. I can start from Leopard DVD, and use terminal, and can see that my user account is still there. From looking at size of files, looks like everything is still on disk, just can't login. Tried using both short name and full display name. Anybody got any ideas?

    PS gotta go, wife wants her computer back
     
  4. viggen61 macrumors 6502

    Joined:
    Jul 24, 2002
    Location:
    New Jersey
    #4
    Fixed!!!!!!!

    Found this on the Apple :apple: Support site:
    Mac OS X 10.5: Unable to log in to account after an upgrade install :)

    Worked like a charm. Just be careful: type EXACTLY what they tell you, substituting the user name where indicated. I used the "short" version of my user name. Your Mac should boot real fast into single user mode, and you'll be done as fast as you can type...

    Looks like those of us old enough to have used Panther or even earlier (I installed 10.0, but when 10.1 came out, it became my default...) might have this issue...
     
  5. webcoyote macrumors newbie

    Joined:
    Oct 8, 2002
    #5
    A couple of solutions

    Visit http://docs.info.apple.com/article.html?artnum=106290 to learn how to enable root user. This should give you access to the files you need to use.

    Visit http://docs.info.apple.com/article.html?artnum=306840 for information about how to fix the password problem.

    This password issue really freaked me out!

    good luck,
    Lee
     
  6. theoxmd macrumors newbie

    Joined:
    Oct 27, 2007
    #6
    I tried apple's solution and it didn't work. Any other guesses?
     
  7. ximota macrumors newbie

    Joined:
    Oct 27, 2007
    #7
    Almost sounds like your user has been deleted, try the following.

    Reboot your computer into single user mode and issue the following commands:

    mount -uw /

    launchctl load /System/Library/LaunchDaemons/com.apple.DirectoryServices.plist

    dscl . -create /Users/[YourUserName]
    dscl . -create /Users/[YourUserName] name [YourUserName]
    dscl . -create /Users/[YourUserName] passwd "*"
    dscl . -create /Users/[YourUserName] hint ""
    dscl . -create /Users/[YourUserName] uid [YourUID]
    dscl . -create /Users/[YourUserName] gid [YourUID]
    dscl . -create /Users/[YourUserName] home /Users/[YourUserName]
    dscl . -create /Users/[YourUserName] shell /bin/bash
    dscl . -create /Users/[YourUserName] realname "Your Name"
    dscl . -create /Users/[YourUserName] sharedDir Public


    dscl . -create /Users/[YourUserName] _shadow_passwd ""
    dscl . -create /Users/[YourUserName] _writers_hint [YourUserName]
    dscl . -create /Users/[YourUserName] _writers_real_name [YourUserName]


    dscl . -create /Groups/[YourUserName]
    dscl . -create /Groups/[YourUserName] name [YourUserName]
    dscl . -create /Groups/[YourUserName] passwd "*"
    dscl . -create /Groups/[YourUserName] gid [YourUID]

    dscl . -merge /Groups/admin users [YourUserName]
    dscl . -merge /Groups/appserverusr users [YourUserName]
    dscl . -merge /Groups/appserveradm users [YourUserName]

    passwd [YourUserName]

    reboot
     
  8. ferric macrumors newbie

    Joined:
    Oct 28, 2007
    #8
    Thank you - that worked perfectly!!!

    Had the exact same problem - but mine was probably caused because the older install DVD was defective and quit halfway through the process taking all users with it.

    Anyway, the new install DVD could see the users and let me change their passwords but when I booted I could only see the 'Other' account and no user/password combination worked.

    I used the info below to create an old account (guessed the UID/GID as 501/501) and it worked like a charm.

    My question is this: if the install DVD can see the older users, why aren't they there on the system anymore???


     
  9. Sofus Comer macrumors newbie

    Joined:
    Oct 29, 2007
    #9
    I also had the same problem many of you had with the new installed 10.5 somehow disabling the administrator priviliges. I could log in with my old username, but couldnt do anything requiring an administration password. My username had changed to a standard username without administrator privileges.

    Solution:
    I remembered that there was a RESET PASSWORD option available when installing the OSX 10.5 Leopard DVD.
    1. Reboot with your OSX 10.5 install DVD and holddown the C button while starting up.
    2. You have to pass the Choose language part and also agree to terms.
    3. When you get to select which disk to install OSX to dont go further, but instead take the top menu where you among others can choose disk utility etc. Here wyou should find the RESET PASSWORD.
    4. You can then choose to change password for the old username, but also the root. Change the root (administration) password and reenter.
    5. Now quit the installer and reboot normally with the startup disc.
    6. Login with username: root and the new password. (Maybe you have set your mac to automatically login and thats ok. Just as long as you get to where you can go to the SYSTEM PREFERENCES and choose the accounts (two people in silhuet icon). Here you can select your old username and because you have the root login, you may enable administrator privileges to this username.
    7. Voila... well it worked for me.

    PS, Apple :apple: should really be so ashamed of this bug. Its so big and i reckon thousand of pour people are more than lost here and in this process i guess thousands of valuable files are being erased cause newbies dont know what else to do than reinstall everything. I was very close to doing this.:(
     
  10. whawhat macrumors 6502

    Joined:
    Jun 9, 2006
    #10
    thanks but it's not working fo rme.....
     
  11. whawhat macrumors 6502

    Joined:
    Jun 9, 2006
    #11
    so when i am prompted, this is what i am suppose to type in?
     
  12. vour macrumors newbie

    Joined:
    Oct 29, 2007
    #12
    This fixed problem for me.

    Thank you! typing "root" as the username after following these instructions allowed me to allow "admin" access back to my regular user account.

    On an additional note, I did a reinstall and that didn't work. Of course it wasn't a clean disk reinstall and from what I understand reinstall archives the old OS and keeps all the config files...so the problem persisted. Again, thanks.


     
  13. im2nice macrumors newbie

    Joined:
    Oct 30, 2007
    #13
    i tried Vour's way and it didnt work for me. I keep getting that even if I changed the password it will not login because i need a login key chain. Is there another way And how do you change your keychain???
     
  14. SKOP macrumors newbie

    Joined:
    Oct 30, 2007
    #14
    Can't Login, Other comes up only

    I need some desperate help... I have been unable to get this fix to work. It is not that I don't think it works, it is only because I don't fully understand the back end of computers. How do I find what the UID (YourUID) is for my account and what do I enter for "Your Name" as well as what do I enter for "*".

    I know this seems really basic, but I am desperately tying to fix my mac so I can use it for work

    - Cheers
     
  15. rob finch macrumors member

    Joined:
    Mar 24, 2006
    Location:
    England
    #15
    SKOP, "Your Name" is just that, it's your real name to associate it with the account you want to create. "*" is the password you wish to use for the new account, so type the password instead of the "*".

    There is another option in the Reset Password utility on the install DVD which resets the user account's home directory. This enabled me to login, as my data partition (that held my home directory) had file system errors that could not be repaired. I had to erase it then restore from my .Mac backups, but I was able to use my login once I had a home directory for it to find!
     
  16. gikku macrumors regular

    gikku

    Joined:
    Dec 29, 2006
    Location:
    -33.82,151.26
    #16
    I had the same issue. I solved it by installing Leopard again, just reboot and run the installer again, but the second time I did an Archive and Install (the first was an upgrade). Fixed.
     
  17. salmon macrumors regular

    Joined:
    Aug 13, 2004
    Location:
    Nova Scotia, Canada
    #17
    So I have an upgrade that has problems pretty similar to these, but slightly different. Bascially, the old user account is still in the /Users directory, with all the files in it, but isn't recognized as an account anywhere. The old account is /Users/{Firstname}{Lastname}

    To find this out, I did the password reset thing (the old account didn't show up as an option for this utility though - just the root account). When I logged in as root, I created another account called {Firstname}.

    The strange part is, is that this new account has access rights to the old account. Indeed, if you look at permissions on the old account, it has the new user of {Firstname} as the owner, with a gid of 501. I'm guessing when I created the new user account, it reused the same uid.

    So, I'm not quite sure the best approach to take from here:
    • Move everything from the old folder to the new folder, and just change the group ownership of everything to 'staff'. This seems to be the best option, but is there any risks before I do it?
    • follow some subset of the steps laid out by ximota to get the old account working again.
    • Something else.
    Please advise. Thanks!
     
  18. brianonhisown macrumors newbie

    Joined:
    Oct 9, 2008
    #18
    Yes!!!

    Thank you, thank you, THANK YOU!!!

    I was having the same problem (Updated from my first Mac - OS 10.4, had an issue in my original installation, and couldn't log in under any username) and this totally worked for me. I was freaking out.

    For anyone else for whom this is the first time they've ever worked in single-user mode, here are a few things that aren't stupidly obvious that I guestimated:

    I didn't actually include any of the quotation marks. I used the same password for the shadow password (even though there's no *) I used 501/501 for UID/GID. I did actually use the username at that last 'passwd' rather than the actual password - it asks for that later, and no, you won't see what you're typing.

    Unfortunately, I thought this would be a good time to set a different password than before, so I still have to use my old one for keychain items I had previously installed.

    Thanks again!


     
  19. tlng13 macrumors newbie

    Joined:
    Jun 16, 2008
    #19
    i finally upgraded my G5 from 10.4 to 10.5, and i experienced the same situation as unable to login, following the instructions from apple web site, such as "reset password" from the 10.5 disc but didn't work...

    i couldn't believe apple made such stupid mistake, or is it only a bug, but this is really awful experience... :mad:

    so i found this post and got it solved by ximota post, i started a new user account and login to 10.5....

    then i thought everything is going to be fine, i thought i could easily take back my account but it's NOT! :mad:

    my accounts from 10.4 is not avaliable in the account pref, but all my users data are sitting right in my hard drive...

    is there anyway to get my accounts working back? like transfer them to 10.5 or moving around these files...

    or i don't mind downgrading to 10.4 as long as getting my user account..

    i'm so regretting about decide to upgrade :(:(:(
     

Share This Page