Serious Macbook Airport Problem...

Discussion in 'MacBook Pro' started by bigben334, Oct 11, 2006.

  1. bigben334 macrumors regular

    Apr 30, 2005
    my macbook doesnt connect to the internet anymore!!!!! this is very bad...while i was connected to my wireless network....i was in the system preferences and i clicked on network and i played around with the "tcp/ip" area of the airport section....i think i might have hit "renew dhcp lease" or i might have changed the configure ipv4 drop down menu to something else besides using not sure...i hit something weird like an idiot and now i cant get an internet macbook sees my wireless network and connects to it but i cant get online because it doesnt acquire an ip address...also, when i connect through ethernet...the same thing doesnt get an ip address...and i know its not my wireless network because my brother's windows laptop is just fine and dandy...somebody please help!!!!:( thanks in advance
  2. Mafio macrumors member

    Sep 29, 2006
    Hello Big Ben,

    I had the same problem; Solution (worked for me):

    "- Pull these to your desktop:
    /library/Preferences/system configuration folder
    - Restart the computer
    - Once up, go into System Preferences > Click Assist me at the bottom > choose Assistant.
    - Walk thru the setup to join your network
    - Once done, in network preferences goto the airport settings, Make sure you choose your network as the prefered.
    - Restart the computer
    - If it works you can feel free to trash the stuff on the desktop, the OS recreated the files from scratch and they are not needed. "


  3. edonn macrumors newbie

    Oct 23, 2008
    It solved MY macbook problem!

    Thanks Mafio!

    I was experiencing the exact same problem. I hadn't used my Mac for a day, dabbling with Ubuntu instead; when I logged back in the following morning I realised that the computer though hooked up onto the network was not being assigned a network address.

    If I'm not wrong, Mafio's instruction removes all previously saved network configurations. I strongly suspect that I had accidentally clicked "Deny" to allowing configd (or a process with a similar name) to access the net, and that may have blocked out communication between the router and my computer. Removing the original preferences reset the preferences and if I'm not wrong reset the firewall settings blocking the communication.

    This solved MY macbook problem! Once again, cheerios Mafio!

Share This Page