Serious problem: iPhone no longer works after update!!

Discussion in 'iPhone' started by skeen, Aug 1, 2009.

  1. skeen macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #1
    Hey all,

    Quite frustrated here. I updated to the new 3.0.1, and at some point an error popped up saying "Unknown error 21". Fair enough I thought, restart my iPhone and update some other time.

    Now it just goes into DFU mode, and itunes tells me I have to restore it. But when I do that, guess what error I get? "Unknown error 21".

    What a huge mistake updating was! Now I have no working phone!

    Any idea what I can do to resolve this? Thanks.
     
  2. PhightinPhils26 macrumors 6502a

    PhightinPhils26

    Joined:
    Sep 12, 2007
    Location:
    Philly
    #2
    Try pushing and holding the top button and home button to reset the phone it will reboot and tell you to restore... Try again. I updated with no problem...
     
  3. skeen thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    London, England
    #3
    That doesn't work. No matter what I do I get the error. So far I have tried switching to a different USB port, removing the software update files (re-downloading the update), and I am now trying to restore it on a different computer.
     
  4. krayziekray macrumors 6502

    Joined:
    Sep 24, 2008
    Location:
    127.0.0.1
    #4
    Have you tried chucking the iPhone into DFU mode and trying a fresh restore?

    :apple: KrayzieKray :apple:
     
  5. ibuyufo macrumors 6502

    Joined:
    Sep 22, 2007
  6. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #6
    Does it do the same thing on another computer, too?

    -- Nathan
     
  7. ryanxslabaugh macrumors member

    Joined:
    Jun 9, 2008
    #7
    I"m having the same problem.

    Was your phone jailbreaked?

    I'm going to the Apple Store tomorrow to have them check it.
     
  8. taigapup macrumors newbie

    Joined:
    Aug 6, 2009
    #8
    phone stopped working after attempted to install 3.0.1

    I tried installing 3.0.1 today and my iphone gave me error 1604. Then it told me to restore. I attempted to restore, but that failed with error 3004. I tried rebooting, I tried checking for a more recent version of itunes, I tried powering off iphone, I tried resetting by holding both buttons until the apple appeared. I tried using another usb port. My iphone is stuck in a mode where it has a picture of the usb cable pointing to itunes. Help!
     
  9. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #9
    That's restore mode. You need to get into DFU mode.

    Follow this clip. Note: wait about 3 seconds after the screen shuts off before you release the power button.

    http://www.youtube.com/watch?v=ofpinyGlQ8I
     
  10. Goodeye macrumors 6502a

    Goodeye

    Joined:
    Jan 30, 2009
    #10
    Simple people take it to the Apple Store and get it replaced or have them fix it.
     

Share This Page