serious problems with Linksys WRT54G router

AHDuke99

macrumors 68020
Original poster
Nov 14, 2002
2,204
27
Charleston, SC
After a year using my old snow airport with my 15" Powerbook, i decided to get myself an 802.11G router to take advantage of my AP Etreme card. I bought a linksys WRT54G router for $59 over apple's airport extreme. When i first conected it, everything seemed to work fine. i forwarded the ports i wanted to forward, named the network what i wanted, and put a password on it. after about an hour of flawless use, things began to act weird.

safari no longer opens when the pbook is connected to the linksys. mail doesn't function, and ichat prints each message twice.

when trying to open safari, console gives me this:
2005-04-16 23:57:56.951 Safari[581] An uncaught exception was raised

2005-04-16 23:57:56.952 Safari[581] *** -[NSCFArray insertObject:atIndex:]: attempt to insert nil

2005-04-16 23:57:56.952 Safari[581] *** Uncaught exception: <NSInvalidArgumentException> *** -[NSCFArray insertObject:atIndex:]: attempt to insert nil
right now i'm writing this on firefox, since it, thunderbird, and AIM all work perfectly. I tried hitting the reset button to no avail on the router. i've never had trouble with linksys routers and this Pbook before.

Help would be appreciated. Thanks... running 1.25ghz PB w/10.3.9
 

Celeron

macrumors 6502a
Mar 11, 2004
704
9
I highly doubt this has anything to do with the Linksys router. Why do you think this? You say that Firefox, Thunderbird, and AIM all work perfectly. All of those apps use your internet connection the same way Safari, Mail, and iChat.

When your connection is broke, its broken for every application, not just a select few.

I think you have a problem with Safari, Mail, and iChat.
 

nichos

macrumors 6502
Jul 17, 2004
372
0
Jacksonville, Fl
I agree with Celeron-try plugging your Mac right into your cable modem and see if you get the same results. Sounds like this calls for a process of elimination.
 

jeremy.king

macrumors 603
Jul 23, 2002
5,479
1
Fuquay Varina, NC
Most definitely not a router issue if select apps are acting goofy. Have you repaired permission, fsck'd, deleted prefs, etc...???

You should be calling Apple support, not Linksys.
 

mkrishnan

Moderator emeritus
Jan 9, 2004
29,777
12
Grand Rapids, MI, USA
One possible common link might be the keychain.... I'm pretty sure that while Mail, iChat and Safari use the keychain, the other apps mentioned, in general, do not. There's another thread here about someone who is unable to access their HTTPS in Safari only, but not FF, after upgrading to 10.3.9... So it seems like Keychain might have something to do wiith a common point of trouble.

Of course, I haven't had any keychain issues. As usual, I was prompted to allow my access rights to be updated for the new system version, and after that, everything worked.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.