Seriously need help with Unibody MBP

Discussion in 'MacBook Pro' started by kurenaiz, Feb 7, 2009.

  1. kurenaiz macrumors member

    Joined:
    Dec 1, 2008
    #1
    I posted a thread very long ago and did i a ton of research but still never find the solution.

    The problem is that my Unibody MBP fails to sleep with the lid open, even if I set the sleep time to 1 min and leave the machine idle for many many nights.

    I have nothing connected to my machine and I make sure that the machine is really idle by closing all the program.

    I even try creating new user and safe boot to check if the problem is caused by the third-party apps, but still my machine won't sleep in safe boot or the new user accounts I created.

    Already reset the pram/smc and the efi?? thingy. Nothing work.

    I used to have the sleep related issue (won't wake up from sleep) when i first got my machine, but it was fixed by the smc/efi update from apple.

    However, this not sleeping when idle that's bugging me seems to be caused by the 10.5.6 update.

    I would want to redo a clean install of leopard, but I don't know how, and worse, I don't have a drive to back up all my data. So, reinstalling is not a viable solution.
     
  2. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #2
    There are a few things you can do other than a reinstall.

    1. Turn on "Restart automatically after a power failure" in System Preferences>Energy Saver>Options. Some have had success with this.

    2. Try the 10.5.6 combo updater from Apple.

    3. Wait until 10.5.7 and hope the update patches things up. :eek:
     
  3. kurenaiz thread starter macrumors member

    Joined:
    Dec 1, 2008
    #3

    Forgot to mention that I already tried the 10.5.6 combo update, but no luck.
     
  4. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #4
    In the preferences there is an option for both AC Adapter and Battery; make sure you set them for each respective one.
     
  5. kurenaiz thread starter macrumors member

    Joined:
    Dec 1, 2008
    #5
    Sad to say, it's not such a stupid mistake.

    Also, i tried looking at the system log, but nothing showed up after one night of sitting idle.
     

Share This Page