service keeps dropping to no service after inserting & activating tmobile

Discussion in 'Jailbreaks and iOS Hacks' started by Sossity, Aug 12, 2011.

  1. Sossity, Aug 12, 2011
    Last edited: Aug 12, 2011

    Sossity macrumors 6502a

    Joined:
    May 12, 2010
    #1
    I recently bought an iphone 3gs jailbroken & unlocked, & bought a tmobile sim card to activate it, I called the number & got it activated, I have an account online & refilled the minutes, but so far I have no service, or it keeps dropping in & out.

    sometimes when I turn on my phone the t-mobile & edge signal bars would show, then it goes to searching, then no service.

    I signed up for a pay as you go plan where I refill minutes as I need them.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    You gotta make sure Enable 3G is turned to OFF in settings/general/network.
     
  3. Sossity thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #3
    this did not really help, when I turned on my iphone after disabling 3g, it started with 2 bars & an E in the top left corner, then to 1 bar, then to searching, then no service.

    some other info that might help; I have found that the search for a signal is slow & signal strength is weak on my tmobile motorola phone, but it never just drops to no service.

    I am on version 4.3.3, & modem firmware is 06.15.00, it starts out reading tmobile as carrier, then as it drops it goes to 10.0, then to no carrier.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Well I know if you leave 3G on then you will have that flunctuation problem and with Tmobile USA you are supposed to shut off 3G on the iphone cause it will cause problems since their 3G bands are not compatible with the iphone.
    Other than that not sure what the problem might be. Make sure your sim sits good in the sim tray and check to see if it maintains good signal on another tmobile phone with edge service only and what kind of bars you get.
    Also try it outside the house. If you're barely getting service with another tmobile phone at that location then you wont get any better signal with the iphone.
     
  5. Sossity thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #5
    I did try it outside my house, I stepped just outside on the front porch, & the same thing happened, about 3 bars& an E, (little better than inside), then drops to 2 bars, then 1 then searching to no service.

    what about other settings like airplane mode? & I notice there was another setting; in settings>general>network>cellular data which I have on, cellular data network, where I can type items, & data roaming which I have on.
     
  6. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #6
    Try the following.

    Take the SIM out of the phone. Power cycle the phone ie. Hold the top button down until you get the slider to turn it off. Slide to turn off and then turn it back on.
    After the phone is back put the SIM back in.
     

Share This Page