Set Home/Away with HomeKit

ipedro

macrumors 603
Original poster
Nov 30, 2004
5,267
6,060
Toronto, ON
I have a Honeywell Lyric. The built in geofence rarely works correctly. I'm looking right at it right now and it says I'm Away.

So instead of relying on the Honeywell app, I'd like to use HomeKit automation. But the only options are: Off/Heat/Cool/Auto.

I'd rather not turn it off because I need it to maintain a safe temperature for my dog. When I come home, I'd like it to resume what it was doing (heating or cooling depending on the season). Instead, I have to set my returning home automation to either cool or heat and have to change that automation every time the weather changes.

Does the Ecobee allow you to set it to Home/Away from the Home app and its automation or is this a limitation of HomeKit itself?

 
Last edited:

chuyn

macrumors 6502
Nov 13, 2015
365
110
Home app doesn't control thermostats all that well. Worse for Canadians too because it doesn't let you set half degrees. If my ecobee was set to 22.5, the home app shows 23. I had the same options with ecobee. I don't have it anymore but when I did, I couldn't figure out how to set it into away mode through the home app. Admittedly, I didn't try very hard because just seeing that it didn't do half degrees made me kind of annoyed and I just relied on the ecobee's smart away feature for entering away mode, and IFTTT to set a geofence to pre-heat/cool when we were on our way home.
 

ipedro

macrumors 603
Original poster
Nov 30, 2004
5,267
6,060
Toronto, ON
I'm willing to be patient. After all, HomeKit is a developing feature in an emerging smart home market. The Home app itself is brand new — not even half a year old. I'm sure we'll see serious progress over the next versions of iOS.

Look at iOS 7. They stripped it down to its bare bones. Over the next couple of versions, it really filled out and came into its own. That's where I think the Home app is right now.

In the meantime, I'm going to try to use IFTTT to do what I want to do.
 
  • Like
Reactions: boston04and07

TheCheapGeek

macrumors 6502
Jul 10, 2008
470
2
I am using my nest in homekit via hombridge. The apple home app does not expose home or away but the popular third part home app does.

I am using a combination of geofencing, motion sensors, and delays to accurately and quickly switch from home to away.
 

munpip214

macrumors regular
Feb 21, 2011
205
423
Does the Ecobee allow you to set it to Home/Away from the Home app and its automation or is this a limitation of HomeKit itself?
Just got an ecobee and managed to figure this out. I knew it could be done since you can tell Siri to set it to home or away. You can't do it through eve or home app, but you actually do it through ecobee app with scenes:

Account - Manage HomeKit - Scenes - <Pick a Scene> - Turn on ecobee - Set desired settings.

For instance to set yourself home, set:

Use - comfort setting - Home for the "I'm home" scene. Then you can just tap that scene in the home app or control panel.

Note: This will add it to your existing parameters for the scene. Also, it won't show up in eve but will in Home, but the values are incorrect. You can just ignore them. For me it was turned off and 45° for sleep, home, and away, but the scenes worked correctly.

Then you can set up a geofence in home or eve that sets "I'm home" scene once you are home.
 

Attachments

  • Like
Reactions: ipedro

BrettStah

macrumors member
Sep 17, 2016
43
14
Funny enough, ecobee' support wasn't able to tell me this. Thank you.
Have you tried setting up a larger geofence? I find that if it's too small you're phone's location can bounce around some on the map (something to do with cell phone towers, I suspect). But if I have a larger one then even if it does that, my iPhone still is inside the geofence.
 

hokiepokie07

macrumors 6502a
Jun 20, 2009
601
11
I've had trouble with this as well with my Ecobee3 and finally just removed it from my scenes. I had issues with it not going back to my schedule at night when I'd go to bed and many other issues. I spoke with Ecobee and they said it was an issue where HomeKit would trump Ecobee and you have to have a scene to get the Ecobee to go back to its schedule.
 

vondo

macrumors member
Feb 22, 2013
43
6
Just got an ecobee and managed to figure this out. I knew it could be done since you can tell Siri to set it to home or away. You can't do it through eve or home app, but you actually do it through ecobee app with scenes:

Account - Manage HomeKit - Scenes - <Pick a Scene> - Turn on ecobee - Set desired settings.

For instance to set yourself home, set:

Use - comfort setting - Home for the "I'm home" scene. Then you can just tap that scene in the home app or control panel.

Note: This will add it to your existing parameters for the scene. Also, it won't show up in eve but will in Home, but the values are incorrect. You can just ignore them. For me it was turned off and 45° for sleep, home, and away, but the scenes worked correctly.

Then you can set up a geofence in home or eve that sets "I'm home" scene once you are home.
The problem with attaching Ecobee scenes to settings like this is that they also put the thermostat into "hold" mode. So if I say "Good night" then it stays in night mode until the next time I manually change it or change it with Siri. I'd use this functionality if you it would change the mode until the next scheduled change, but as it is, it's worse than just using the timed modes + motion detection, IMO.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.