Set thunderbolt ethernet priority.

Discussion in 'MacBook Pro' started by gentlefury, Aug 1, 2012.

  1. gentlefury, Aug 1, 2012
    Last edited: Aug 1, 2012

    gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #1
    OK, so I have a bit of an issue. I bought a thunderbolt to ethernet adapter, and it works great! Problem is tho, when I go into network prefs it doesn't show up as a device. Its working fine, but its not listed. And when I manually add it, it shows up with no IP address.

    None of this really matters, the problem tho is that I can't set it to have priority over wifi...so I have to actually disable wifi to use wired. Which is annoying. Does anyone know a workaround here? Or is this just early adoption woes that should be ironed out in a revision or two?

    Of course in windows, it defaults to the ethernet....wtf...why is windows running better on this thing than Mac???
     
  2. katmeef macrumors 6502

    Joined:
    Jul 20, 2010
    #2
    I had a bit of an issue with my TB>GbE being recognized as a Bluetooth connection in network prefs, mentioned here http://forums.macrumors.com/showthread.php?p=15284226#post15284226 in a thread regarding a problem I'm having with the TB>GbE, specifically when using time machine to a USB drive hanging off my iMac. Eventually got the TB>GbE adapter back by trashing /Library/Preferences/SystemConfiguration/preferences.plist and rebooting before reconnecting the adapter
     
  3. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #3
    whats wrong with having wifi off? makes sense to save battery.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    It would be good to leave wi-fi on so Find My Mac works if someone steals your Macbook.
     
  5. gentlefury thread starter macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #5
    yes, find my mac is a big reason.

    ----------

    That did it! Perfect! Thanks! I was wondering why it was saying Bluetooth was connected. Makes sense now!
     
  6. katmeef macrumors 6502

    Joined:
    Jul 20, 2010
    #6
    You're welcome :)
     

Share This Page