Setting Audio Out to Line Out rather than internal Speakers - Not sticking

Discussion in 'Mac Pro' started by milbournosphere, Aug 31, 2010.

  1. milbournosphere macrumors 6502a

    milbournosphere

    Joined:
    Mar 3, 2009
    Location:
    San Diego, CA
    #1
    So I have my '10 Pro setup with some Logitech speakers to use as audio out. I have gone into the preferences pane and set the sound to go through the speakers, rather than the internal speaker. All is well until I reboot the machine; the setting does not appear to be sticking after a restart. Any ideas?
     
  2. lssmit02 macrumors 6502

    Joined:
    Mar 25, 2004
    #2
    Sorry for the bump on this, but I'm having the exact same problem on a 2006 Mac Pro. Any solutions?
     
  3. GlynJones macrumors 6502

    Joined:
    Jun 15, 2005
    #3
    Same here on a 2006. If I go into Sound Settings on Systems Preferences it starts working again. Weird.
     
  4. milbournosphere thread starter macrumors 6502a

    milbournosphere

    Joined:
    Mar 3, 2009
    Location:
    San Diego, CA
    #4
    Still haven't found a solution to this...does anybody out there have one? I'm only bumping because at least a few people besides me are having this problem. I know it's not the speakers. I just upgraded to a set of creatures, and I am still having the problem. Any ideas?
     
  5. Loa macrumors 65816

    Loa

    Joined:
    May 5, 2003
    Location:
    Québec
    #5
    Hello,

    Usual suspect: preference file not allowed to be properly saved. Have you guys repaired your permissions lately?

    Loa
     
  6. R.OG macrumors regular

    Joined:
    Aug 19, 2010
  7. milbournosphere thread starter macrumors 6502a

    milbournosphere

    Joined:
    Mar 3, 2009
    Location:
    San Diego, CA
    #7
    Problem solved. Here's what worked for me:

    1) Trash your /Library/Preferences/Audio folder

    2)
    Code:
    sudo mkdir /Library/Preferences/Audio/
    3)
    Code:
    sudo chown -R _coreaudiod:admin /Library/Preferences/Audio/
    This should trash and reset you audio preferences. Probably some issue from when I migrated my data over from my old box. Anyways, problem solved! Off to listen to some Pink Floyd. :) Thanks for all the help, as usual these forums are great.
     

Share This Page