Setting iCloud Photo Library or Photo Stream to only upload certain photos?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by 0dev, Jul 5, 2015.

  1. 0dev macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #1
    I want only some of the photos I take on my phone to get synced up so they go to my Mac and Apple TV.

    But it looks like both iCloud Photo Library and Photo Stream are an all or nothing deal. I have to turn them off completely or upload my entire camera roll.

    Is there not a way I can set either one to upload only photos I choose? I don't want private photos in the cloud, just ask Jennifer Lawrence...

    I know iCloud Photo Sharing lets you create albums which are shared so the rest of your photos remain on your phone, but that doesn't seem to be compatible with Apple TV so it doesn't do what I need it to.
     
  2. 0dev thread starter macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
  3. Paco II macrumors 65816

    Joined:
    Sep 13, 2009
    #3
    Don't have an Apple TV but Apple FAQ says Apple TV supports iCloud photo sharing.
     
  4. 0dev thread starter macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #4
    That's interesting because in the Apple TV settings there is no option to turn on iCloud Photo Sharing and when I made shared iCloud albums they didn't show up on the Apple TV.
     
  5. BadgerRivFan macrumors newbie

    Joined:
    Oct 6, 2013
    #5
    Is it possible that you need to update your Apple TV software or that you have a previous generation ATV that does not support iCloud Photo Sharing? I have an ATV3 that I was able to set up with a shared photo album and that is how I am doing exactly what you describe.
     
  6. 0dev thread starter macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #6
    I'm a moron! iCloud Photo Sharing is in the Apple TV and after making an Apple TV album on my phone then restarting the ATV it now shows up. Thank you!
     

Share This Page