'Setting Time Zone' keeps turning on by itself

Discussion in 'iOS 10' started by laszlo182, Apr 25, 2017.

  1. laszlo182 macrumors regular

    Joined:
    Nov 17, 2013
    Location:
    Bratislava, Slovakia
    #1
    I have noticed that sometimes when I wake my iPhone up this little arrow signalizing some service is using my location keeps popping up for a second then it disappears. I know that if you open Privacy > Loc. Services quickly enogh you can see purple icon next to an item that has recently used the location, so I started my hunt for the culprit. Never have I ever seen the purple icon.

    Then I noticed that there's a gray icon next to 'Setting Time Zone' which I have turned off almost forever just like most of the items in 'System Services' category to save battery (note that I have a 'Status Bar Icon' toggle turned on). Can somebody suggest a solution or do you know why is this happening? I tried turning it on and of again :D I have a 6s and the latest OS.

    It is really weird that something can bypass that toggle...
     
  2. imagineadam macrumors 6502a

    Joined:
    Jan 19, 2011
    #2
    Same here. Mine didn't start doing that till I got my Apple Watch... Do you have an Apple Watch?
     
  3. imagineadam macrumors 6502a

    Joined:
    Jan 19, 2011
    #4
    Yup. Looks like it's a new 10.3-10.3.1 bug. My 5c does it too and it isn't connected to an Apple Watch and the setting is switched to off for setting time zone. And yes the gray arrow is next to it.

    Anybody know if this is fixed in 10.3.2?
     
  4. mcjoebundy, May 13, 2017
    Last edited: May 13, 2017

    mcjoebundy macrumors newbie

    Joined:
    May 13, 2017
    #5
    Same thing here. I've got an iPhone SE on iOS 10.3.1 and have noticed the same thing for a while now. I don't have an Apple Watch. I hope this is rectified in the next iOS update coz it bugs me. I was going paranoid like Quinn in "Homeland" (Season 6) thinking "they" were remotely controlling my cell and monitoring my movements or something... LOL
     
  5. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Still there in iOS 10.3.2. Been around since 10.3 as I recall.
     
  6. DeadKlau5 macrumors member

    Joined:
    Oct 11, 2016
    #7
    its finally fixed in iOS 10.3.3 beta 3 <3
     

    Attached Files:

  7. imagineadam macrumors 6502a

    Joined:
    Jan 19, 2011
    #8
    Hurray!!!:)
     
  8. laszlo182 thread starter macrumors regular

    Joined:
    Nov 17, 2013
    Location:
    Bratislava, Slovakia
    #9
    Back in iOS 11 beta 1 & 2.
     

    Attached Files:

  9. Djilkosh macrumors regular

    Djilkosh

    Joined:
    Dec 3, 2016
    Location:
    Serbia
  10. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #11
    Still seeing the same issue with it using the public 10.3.3 release that came out this week. Seems like it wasn't addressed after all.
     
  11. Djilkosh macrumors regular

    Djilkosh

    Joined:
    Dec 3, 2016
    Location:
    Serbia
    #12
    Yup... I thought they fixed this... I didn't have it after install, just saw now... :mad::mad::mad::mad:
     
  12. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #14
    Being that it is a beta, it might be happening on purpose and not necessarily a bug in the actual builds. Betas don't follow all of users' settings. So, its possible the beta is overriding it. With that being said, issue still remains on 10.3.3 final, as it is happening to my device as well.

    Question to everyone. Has anyone actually seen if that arrow icon has been purple? Maybe the bug in iOS 10.3.x is just showing the grey icon, but its not actually using the service. The service is only used if it is purple. Grey means it was used in the last 24 hours. But there could be a bug keeping it as gray 24/7. Again, I have never seen it as purple.
     
  13. imagineadam macrumors 6502a

    Joined:
    Jan 19, 2011
    #15
    I think it is actually being used since I see the location arrow popping up periodically everyday in the status bar then disappearing after like 1 second or 2. And then I go and check to see what was just using it by looking for a purple icon and there isn't one anywhere. Just the grey setting time zone one. It's a minor bug introduced in 10.3 and I guess they just don't care to fix it it seems.
     
  14. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #16
    And you are positive not a single app, or weather is using the location service? The icon will remain purple for a minute or two after the icon disappears.
     
  15. imagineadam macrumors 6502a

    Joined:
    Jan 19, 2011
    #17
    Yes. For sure.
    --- Post Merged, Jul 22, 2017 ---
    I used to think it was from my Apple Watch using Watch faces but it isn't and I tried it on our old 5c laying around which isn't connected to anything. Same thing. Same bug.
    --- Post Merged, Jul 22, 2017 ---
    Make sure status bar icon is turned on under system settings. And everyone will see it turning on periodically though the day.
     
  16. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #18
    That doesn't explain why the location arrow wouldn't be purple tho. If I flip setting time zone back on, It will become purple and remain purple for a few minutes every time that it is used. But I have never once seen it purple when toggled off. Typically when I see the location arrow on my device, I quickly dig around location services to see what it was. 99% of the time, the culprit is weather.
     
  17. imagineadam macrumors 6502a

    Joined:
    Jan 19, 2011
    #19
    I do the exact same thing and NOTHING is purple so I know it has to be the setting location even though it is toggled off and I've never had it toggled on.
     
  18. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #20
    But you can't for certain say it's time zone, because that same statement could be applied to anything with a grey arrow. We are only guessing it's time zone.
     
  19. imagineadam macrumors 6502a

    Joined:
    Jan 19, 2011
    #21
    But this never happened before 10.3.

    Ill try turning off every location service so there are no other grey arrows possible and report back tomorrow or over 24 hours and I bet the culprit will still be the setting time zone just to be even more sure than I already am I guess!
     
  20. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #22
    I've had the location arrow appear in the status bar when I haven't used any apps or services that use location. Checking the location services settings only setting time zone (which is diaabled) would have a gray arrow next to it. The probable conclusion there that either it is the culprit or something else is which isn't showing up in location services with any use indicator at all. Since the latter possibility doesn't really have much in the way of supporting it compared to the former (especially given that there is in fact an indicator that appears to the setting that is disabled) it seems it's something related to that setting time zone option.
     
  21. Djilkosh macrumors regular

    Djilkosh

    Joined:
    Dec 3, 2016
    Location:
    Serbia
    #23
    You don't need to do that. Been there, done that. Deleted every weather app and maps app and turned off all locations everything change to never and literally turned all locations off (share my location, iPhone analytics, popular near me, routing and traffic), still there is setting time zone gray arrow and sometimes popping up arrow in status bar...

    Did any of you report that to Apple?
     

Share This Page