Setting up a non-plug-and-play printer: HP LaserJet 1100a

Discussion in 'Mac Accessories' started by DealMinded, Jun 21, 2007.

  1. DealMinded macrumors newbie

    Joined:
    Jun 21, 2007
    #1
    Note: The issue is not in getting drivers for the HP LaserJet 1100a. It was a struggle, but I have drivers that allow me to print to it via sharing on Windows machine. However, I'm phasing out all Windows products.

    I bought a USB to Mini-Centronics cable (that's another story and if we can get this to work, I'll tell you about it). The cable works for Macs. I know that; I've tested it with other products.

    Here's where I'm stuck:

    I go into Printer Setup Utility, click Add, click "More Printers..." holding the option key, which gives me an "Advanced" option in the upper drop-down box. I select that. Then it wants "Device", "Device Name", "Device URI", and "Printer Model". I have the Printer Model--HP LaserJet 1100A Footmatic/hpijs. I think I should select USB for the Device. But then I don't know what to put for the Device URI. It fills in usb:// automatically, but am not sure what else to put. I assume the Device Name is meaningless, and anything will work.

    Any help here would be great. Thanks a lot!
     
  2. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #2
    A USB-parallel adapter cable should show up as USB in the Default Browser (oh - we need to know if you're using Tiger or something else) window. If it doesn't or doesn't work, try installing the alternate USB driver "usbtb."

    http://buymelunch.org/printing/usbtb/
     
  3. DealMinded thread starter macrumors newbie

    Joined:
    Jun 21, 2007
    #3
    Thanks for the reply. Sorry, I am using Tiger, and it doesn't show up in the default browser.
     
  4. pvp803 macrumors newbie

    Joined:
    Jun 16, 2007
    Location:
    Washington, DC
    #4
    i got my HP Laserjet 1100 to work with my MBP via usb to parallel adapter. when asked for drivers, try HP LaserJet 6 series - Gimp-beta 2. should be in list of drivers by default in Tiger.
     

Share This Page