Setting up a user account with parental control

Discussion in 'Mac Basics and Help' started by jandevriend, Sep 27, 2017.

  1. jandevriend macrumors newbie

    Joined:
    Sep 26, 2017
    #1
    Hi! I tried setting up a new user account in macOS Sierra yesterday, but the parental control settings didn't stick. I deleted the user account a couple of times and tried to add it again, but no luck.
    So I deleted the account again, and decided to try everything again after doing a software update.
    Last night, I went from 10.12.5 to 10.13, so I'm currently on macOS High Sierra.

    Unfortunately, I can't seem to add any user accounts anymore at all!
    It creates a 'public folder' (if it's even called like that, my computer isn't set up in English) under 'groups' in system preferences... And I can't log in to the just-created account either.
    I tried making a Standard account, an Administrator and a Managed with Parental Control one... No luck.

    Did they change something when it comes to creating user accounts?
    Meanwhile I'm also stuck with three 'public folders', and I can not delete them.
    I select them (all three, but not at once), click the '-'-button and it asks me if I want to delete this. I select 'yes' and nothing happens...

    I tried all of this on an administrator account (and on a standard account, but logged in with the admin password when I unlocked the little lock thingy in the left corner).

    This is pretty much what it looks like: https://s26.postimg.org/elda7mq89/Schermafbeelding_2017-09-27_om_09.04.48.png
    (I know the settings are locked in this screenshot, but they weren't when I tried all of this)

    There's my account (Admin), the TV account (Standard) and I'm trying to add another one with parental controls (as you can see, I made three attempts in creating this account).
    A home folder is added in the Users folder, yet I can not log in from the login screen (when I fill in the username, it shakes as if the password is wrong, even though there is no password).

    I don't know if this is important, but I'm not trying this on the MacBook I use everyday, but on a fairly old MacBook Pro (Late 2011, 13") that I used to use years ago.
    It has 4 GB of ram, a 2,4 GHz Intel Dual Core i5 and an SSD hard disk.

    Could somebody help me, please? Thank you guys so much in advance!
     
  2. jandevriend thread starter macrumors newbie

    Joined:
    Sep 26, 2017
    #2
    Okay update... On this MacBook, the guest account isn't working either...
    I enabled it (log in only) but it doesn't pop up on the log in window. I rebooted the MacBook and everything.

    Am I doing something wrong (like, did they change all of these settings) or is macOS High Sierra just a piece of junk?
     
  3. ApfelKuchen macrumors 68020

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #3
    I'm able to create new User accounts in High Sierra, using the same method I used for previous versions of the OS.

    There's one change that I've found in High Sierra - when you create a new User (gebruiker), it also creates a Group (groepen) for the account's Public folder (the public folder isn't new in High Sierra, only the Group is new). This makes it easier to assign permission to access that Public folder. If you delete the User, the Group for that folder remains in Groups - you have to delete it separately. I have been able to delete the Group in the normal way.

    I'm not sure why you cannot create/modify new Users. Make sure that "Allow user to administer this computer" still has a check-mark for your Administrator account. If you haven't restarted your Mac, try restarting. There's a possibility that your Administrative User account has become damaged.

    I don't have expertise in fixing damaged accounts. You may have to call Apple for assistance.
     
  4. jandevriend thread starter macrumors newbie

    Joined:
    Sep 26, 2017
    #4
    Thanks, ApfelKuchen!

    I forgot to mention that adding user accounts worked fine on Sierra (10.12.5), but after updating to High Sierra (which I only did becuase parental control isn't working the way it should, and I read online that a lot of users experience problems with parental control) it only creates this public folder in the group section, like you mentioned, which I cannot delete...

    I guess I'll have to do a clean install of macOS... I hate to do that, but I don't see any other way.
    There's definitely something wrong with the user accounts though. Even the guest account (which definitely used to work), stopped working.
    It's not worth it to wait for a software update that might not even fix my issue... :/
     

Share This Page