Setting up Ethernet on a MacBook

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Boksney, Nov 25, 2008.

  1. Boksney macrumors newbie

    Nov 25, 2008
    I am currently on vacation and away from my router. I would like to connect my MacBook to the internet, and my brother has an HP laptop here connected to the internet via an ethernet cable.

    I have tried connecting the cable to my MacBook and following these instructions on setting up the connection, yet Safari tells me I have no internet connection and Network Diagnostics cannot fix the problem. Can anybody tell me what I am doing wrong? Thanks.
  2. sammich macrumors 601


    Sep 26, 2006
    I'm not totally sure how to share internet over wifi on Windows but (assuming the HP has wireless):

    Plug the ethernet cable into your MacBook, make sure the internet works. Then go to System Preferences -> Sharing -> Internet Sharing (2nd from bottom). Don't check this box yet

    Select share from your Built-in Ethernet, check the Airport, from 'To Computers using', and go to 'Airport Options' for passwords and naming etc.

    NOW check the 'Internet Sharing' checkbox, make sure the airport is on. Go to the HP and find your new wireless network and put in the right details and ta da!
  3. Nugget macrumors 68000


    Nov 24, 2002
    Houston Texas USA
    sammich, he's not asking the question you're answering.

    The answer is, in 99% of the cases, you enable ethernet on a mac by performing the following complicated steps:

    1. plug the cable into the mac.
    2. congratulate yourself on a job well-done

    If those steps don't work, then there's a problem, and we're probably going to need more information to work you through it. A good first step would be to look and see how your brother has his HP configured.

    Another interesting piece of information would be to look and see what your Mac thinks is happening when you plug in the ethernet cable. In system preferences in the Network section there should be an "Ethernet" connection. Is it green, yellow, or red. What does the state say? It ought to say "Connected" but it probably says something else. That would help diagnose the problem.
  4. Boksney thread starter macrumors newbie

    Nov 25, 2008
    Okay. The plug in the cable and go doesn't work, so there probably is sometihng else going on here. When I open up the Network pane, the inidicator beside of Ethernet is green, and below it says "Self-Assigned IP."

    As for the configuration of the HP, I have no idea. I have zero experience with Windows, so I wouldn't be able to tell you unless you told me where to look.
  5. EricNau Moderator emeritus


    Apr 27, 2005
    San Francisco, CA
    This means that the Mac isn't receiving an IP address from the DHCP server.

    Is this ethernet cable connected through a router, or is it coming directly from the cable modem? If it's the former, try resetting the router, if it's the latter, you can try some of the steps mentioned here:
  6. Boksney thread starter macrumors newbie

    Nov 25, 2008
    The cable's coming from a modem. I looked at the Apple support page, but those instructions appear to be for Tiger. I'm running Leopard..
  7. belvdr macrumors 603

    Aug 15, 2005
    No longer logging into MR
  8. pismobrat macrumors regular

    Aug 13, 2007
    another thought


    Couple of questions

    1) Is there no router/firewall that your brother has?
    2) If not, sounds like he has DSL
    3) If it is a DSL service - eg: Telus here in Canada. The MAC (not related just to apple) is going to be a unique number that is registered to his account and any other devices with a MAC address will not be allowed on to the line w/o being first registered.
    4) If he has a cable modem - then this might require more thinking.

    Let us know if he has DSL or not and we can go from there.
  9. cdcastillo macrumors 6502a


    Dec 22, 2007
    The cesspit of civilization
  10. DoFoT9 macrumors P6


    Jun 11, 2007
    OP it sounds as though the ethernet port is using a static IP, generated because of a previous setting or from the 'unknown'.

    i would suggest going into System Preferences, Network settings, select ethernet and make sure that it is using "DHCP Server" for the IP.

Share This Page