Setting up Gmail on iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by rainmanbk, Jun 30, 2007.

  1. rainmanbk macrumors 6502

    rainmanbk

    Joined:
    Jan 30, 2006
    Location:
    Southington, CT
    #1
    I had a genuis idea when I discovered Google's recent: features, which lets you use your mobile devices without worry that they're downloading your desktop POP3 mail. In order to use it, you put recent: in front of your email address. So if your email was joe@gmail.com, it would be recent:joe@gmail.com. However, the problem I've come across, is on iPhone, when you're typing in the field to set your email address, you cannot type the : character. It is not on the extended keyboard. So I'm not sure how to work around that. I want to receive mail on my iPhone, but I want to get that same mail on my computer, to ensure that I have it backed up properly.

    My only other solution thought was to use recent: on all my computers, and then put the actual address on the phone, so the phone was the main client downloading the mail, and the others were the ones using recent. But I'd rather it be the other way..

    Solutions? Ideas?
     
  2. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #2
    i'm having problems with gmail too. when setting it up, it downloads ALL my messages and says they are all new... and they aren't. i even selected (in gmail) to only send messages from now on... and it still did the same thing.
     
  3. terrrrrible macrumors regular

    Joined:
    Jun 17, 2007
    #3
    try this, i believe it fixed my problem:

    make sure you have "Enable POP only for mail that arrives from now on" selected on your account in gmail, delete the account(s) from your phone, re-add them, make sure "Use Recent Mode" is disabled on the account(s) BEFORE you access the mail. Go ahead and go into the mail. It will pull 25 e-mails (if you have that as your setting) into the inbox, but after you delete them, it shouldn't keep pulling more in.
     
  4. tho macrumors member

    Joined:
    Jun 19, 2007
    #4
    it also sends back a copy of your sent e-mail folder as well. the fix i'm gonna do for now is block e-mails from my own address.
     
  5. terrrrrible macrumors regular

    Joined:
    Jun 17, 2007
    #5
    did you accidentally enable "Always Cc Myself"?
     
  6. mostman macrumors regular

    Joined:
    Aug 24, 2006
    #6
    Nah - I have the same problem. And I ended up on the same solution - delete mails being sent by me. Its because of the way that google does its folder hierarchy - everything is in one folder.

    The iPhone will need a fix for this - to be able to filter them out.

    -Mike
     
  7. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #7
    what is "use recent mode"? i mean, i know where it is and how to turn it on... i just don't know what it does exactly.
     
  8. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #8
    where did you set it up to block emails from yourself? in the iphone or in gmail? i'm having the same problem.
     
  9. digitaldave macrumors regular

    digitaldave

    Joined:
    Apr 6, 2006
    #9
    Or you could set up a rule in your mail client to move items from yourself to the sent folder - that's what I do, and it works fine :).

    EDIT - I have no idea if you can set rules in the iPhone mail client, I was referring to Mail.app.
     
  10. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #10
    ugh, gmail is a pain on here. i'm just not going to use that account on my phone for now. i can't get it working right.
     
  11. lord patton macrumors 65816

    lord patton

    Joined:
    Jun 6, 2005
    Location:
    Chicago
    #11
    same problem here, looking for a fix.

    Perhaps the "always cc yourself" option doesn't work correctly yet.
     
  12. mac-er macrumors 65816

    Joined:
    Apr 9, 2003
    #12
    Do this....

    Instead of setting up your Gmail account on iPhone through the "Gmail" link when you first touch "Mail", click the "Other" category, that lets you put in all the login and server information.
    Your email address will still be joe@gmail.com, but under the incoming mail server settings, your user name will be recent:joe@gmail.com. Your user name for outgoing will be joe@gmail.com

    I just tested it, and I was able to get a mail off my iPhone (and delete it), and then when I went into Mail.app on my Mac, it was there.

     
  13. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #13
    POP is a bad when youre trying to use it on multiple devices to keep a mailbox in sync hopefully gmail will implement imap soon!
     
  14. mac-er macrumors 65816

    Joined:
    Apr 9, 2003
    #14
    Per Google:


    It's how Google stores mail on their servers. Somehow, we need to be able to create a sent folder on iPhone to categorize the mail. Haven't figured that one out yet...

    EDIT: iPhone mail will create a sent folder the first time you send a message and a drafts folder the first time you save mail to send.

    However, creating those folders did not fix the issue of the iPhone mail not categorizing the mail (so mail I sent was still being downloaded into the inbox). And, you still want to keep copies of mail you send on your client.

    I did find a workaround:
    1. Go to Gmail.com and create a filter that says that mail with from your email is to be deleted. Sent mail will go to the trash on the Gmail servers (which stays there for like 30 days).
    2. iPhone Mail will not pull from the Gmail trash, so you will not get copies of the email you sent in your iPhone mailbox.
    3. Copies of mail you send will still be on the iPhone "Sent" folder, and more importantly, Mail.app on your Mac will also keep a copy, so filtering through Gmail shouldn't impact your archiving of sent mail.
     
  15. lord patton macrumors 65816

    lord patton

    Joined:
    Jun 6, 2005
    Location:
    Chicago
  16. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #16
    great advice... but what happens with the email you said from within gmail itself from a computer? it would all go to the trash, right? i'd like to keep my sent emails in the sent folder and not have them be deleted.
     
  17. mac-er macrumors 65816

    Joined:
    Apr 9, 2003
    #17
    If you are using a mail client, like Mail.app, it will keep them for you.
    If you are using Gmail.com, they will go to the trash, where Gmail keeps them for a period of time.
     
  18. Diode macrumors 68020

    Diode

    Joined:
    Apr 15, 2004
    Location:
    Washington DC
    #18
    Thanks for this!
     
  19. rainmanbk thread starter macrumors 6502

    rainmanbk

    Joined:
    Jan 30, 2006
    Location:
    Southington, CT
    #19
    Great.. it looks like mac-er's idea will and does work.. I have yet to try it but I am almost positive that this is the answer. Thanks all for helping solve this!
     
  20. sunnywala macrumors newbie

    Joined:
    Jun 25, 2007
    #20
    I wish there was an awesome gmail app, like I had for my blackberry...maybe soon
    I set mails sent from me to archive(skip inbox) it seems to work
     
  21. Pine-Tree macrumors member

    Pine-Tree

    Joined:
    Sep 14, 2005
    Location:
    Arizona, USA
    #21
    I was also having issues with gmail. I used that tip of creating a filter, and it works!! thanks! If google does come out with a fix, we'll have to go back and take it out right??
     
  22. technicolor macrumors 68000

    technicolor

    Joined:
    Dec 21, 2005
    Location:
    ><><><><
    #22
    I am very frustrated.

    I have archived all the email in my inbox, and some how my phone still says I have 25 new messages.:rolleyes:

    I used both the gmail and other link in the account setup.

    There is absolutely nothing in my inbox!
     
  23. Pine-Tree macrumors member

    Pine-Tree

    Joined:
    Sep 14, 2005
    Location:
    Arizona, USA
    #23
    custom gmail accounts

    I have a regular gmail account, which is working fine so far on my iphone. I also have a custom e-mail (google apps) that I have after getting a domain name from them, basically xxx@azsunnyside.com. It seems to work for sending e-mail but it doesn't receive any e-mails even though there's some there currently. I checked by sending an e-mail to my address and it went through my mail.app on my laptop, but not on iphone, am I doing something wrong?? Is there a different way to configure an e-mail that is through google apps? Any help will be much appreciated.

    Abe
     
  24. mogema macrumors newbie

    Joined:
    Apr 30, 2004
    #24
    Recent mode is a lifesaver!!

    I was PISSED when I saw the iPhone downloading all my archived mail.. mostly because I have over 20k messages archived.

    Recent mode syncs all mail from the last 30 days, which brought my total to under 500 messages. This was still frightening, so I just went and deleted most of the unnecessary mail from the past 30 days in gmail BEFORE re-creating the gmail account on the iPhone. Now I'm down to 32 messages :) ( I should really learn to use that delete button in gmail :p )
     
  25. mogema macrumors newbie

    Joined:
    Apr 30, 2004
    #25
    Hey Abe - I also have a google apps address and don't know how many times I've caught myself using mail.myapp.com or pop.myapp.com instead of pop.gmail.com. You might also want to try pop.googlemail.com port 995.

    Double check that you're logging in with the full email address as well - xyz@myapp.com

    Otherwise... *shrugs*

    I'm actually using gmail's accounts feature to fetch my google apps mail into my gmail account (there, you HAVE to use pop.googlemail.com because pop.gmail.com won't let you fetch from other gmail accounts, but googlemail.com will).

    Replying from gmail's webapp will send as the google apps address if it was the recipient.. I dunno about the iPhone... hmm

    [UPDATE]: Mail fetched into Gmail from other POP3 account via Gmail's accounts feature won't retain the correct sender address when being sent from the iPhone... bummer.
     

Share This Page