Settings animation bug (9.2 final - 9.3 beta)

Discussion in 'iOS 9' started by mtx4, Jan 18, 2016.

  1. mtx4 macrumors member

    Joined:
    Jan 18, 2016
    #1
    Hello, I'm Marco and I'm here to report a bug that noone have osserved in new releases.
    This bug affects every iphones since 9.2 firmware, but it was no present in 9.1
    It's a cosmetic bug that appear when you tap a voice in settings, for example Facebook, Flickr but also battery, phone, messages and so on. (Not happens in wifi, blueetoth,notifications and the first voices of settings)
    The first time you tap a voice, there is not a smooth slide into the new page, but the principal settings page moves up or down like a little jump. So the transitions is not smooth and you can see it every time you enter for the first time into a menu. Second time is smooth but it's enough close setting and open it again to see the bug when tapping a voice.
    I don't know if my explanation is understandable, but for me is a huge issue, because never I have seen such similar behavior in any previous build.
    The strange thing is that nobody seems to report this problem !!!
    So please, there is a way to report this bug ?
     
  2. Suckfest 9001 macrumors 6502a

    Suckfest 9001

    Joined:
    May 31, 2015
    Location:
    Canada
    #2
    It was part of their hacky solution to the settings menu not being scrolled up all the way when first opened. Seems now there's a "position saving" feature now hence the delay, but it's buggy since it makes the position jump a bit.

    There also seems to be a minimum scroll distance under which it won't re-save. For example, click on a page, then click back, then scroll a few pixels. It won't re-save and the page will open with practically no delay as a result.

    So yeah. Not exactly "world-class engineering" that I'd expect from a $300-billion company (neither is my iCloud Backup storage being corrupted and undeletable but that's another issue).
     
  3. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #3
    Plenty discussions of all kinds of framedrops and stutters and inconsistencies in smoothness that some people experince for months now, even every specific individual location isn't called out all the time or even often.

    The place to report it all is at http://bugreport.apple.com
     
  4. mtx4 thread starter macrumors member

    Joined:
    Jan 18, 2016
    #4
    So I'm not crazy, the bug is there, but I don't see it in any unofficial report, in this forum too.
    I think is one of the important things because it's related to appearence and interface.
     
  5. mtx4 thread starter macrumors member

    Joined:
    Jan 18, 2016
    #5

    This bug was not fixed also in 9.3 beta 2.
    Still very dissapointed !!
     

Share This Page