Settings for mail notification

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MiniGeek, May 26, 2016.

  1. MiniGeek macrumors member

    Joined:
    Apr 10, 2016
    #1
    I've noticed that since I've had my iphone 6 replaced, the way the newest phone deals with my email has changed. I used to get notified with a sound and a number on my mail icon when there was new mail. Now that no longer happens. The phone doesn't seem to be receiving the mail unless I actually open the app. I have a gmail account.

    Can anyone tell me what my settings should be? I would like the mail pushed to my phone from the server and I would like a sound notification. When I got to Settings->Notifications->Mail, I have Allow Notifications set to on. I do not have it showing in notification center. I have a sound for notification. Badge App icon is on. Show on lock screen is off. For Alert style when unlocked, I have 'none' selected.

    For Settings->Mail, Contacts, Calendars, under Accounts, Gmail is toggled on. Fetch new data is set to Push. Push is on. Gmail is set to Fetch. I had Fetch set to manual, I just changed it to "Every 30 minutes". I know I have unopened email in my gmail account, and nothing is showing up on my icon. I've just sent a new test email to my gmail account, and nothing shows up on the phone.

    What am I doing wrong? The only time my phone now gets email is if I actually open the mail app.
     
  2. MiniGeek thread starter macrumors member

    Joined:
    Apr 10, 2016
    #2
    Figured it out. I toggled off the Push setting for Fetch new data, and that worked. Odd, I would have thought the opposite...
     

Share This Page