Settings/General/date & time/24-Hour Time button inactive

Discussion in 'iPhone Tips, Help and Troubleshooting' started by miphone, Jul 19, 2008.

  1. miphone macrumors newbie

    Joined:
    Jul 17, 2008
    #1
    Hi, the 24-Hour Time button in Date&time in General in Settings on my phone is inactive , i seems to have tried everything i knoew but it just wont get active .... can anyone please suggest remedy!!

    also.

    why does my WifI doesnt work when i get a foreign Wifi signal(even know they are open access wifi, unloked) my WIFi setting : DHCP/AUTO and DNS is set to 208.67.222.222 or 208.67.220.220 i read this shud suit any wifi my iphone catches... please comment... thanks for reading..
     
  2. ventmore macrumors 6502a

    Joined:
    Jul 13, 2008
  3. miphone thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #3
    Hi, its already on AUTO!!! any other suggestion,
     
  4. ventmore macrumors 6502a

    Joined:
    Jul 13, 2008
    #4
    Not according to your first post it isn't :)
     
  5. miphone thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #5
    Anyways , please hel pme out here,, thanks for reading mate.
     
  6. ventmore macrumors 6502a

    Joined:
    Jul 13, 2008
    #6
    You currently have DNS set to 208.67.222.222 or 208.67.220.220. Try setting it to AUTO and see what happens. It may not make much difference, but it's worth a try.

    BTW...Have you been able to connect to any open networks at all, or are you having problems with every open network?
     
  7. miphone thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #7
    Hi mate,

    Yes its on auto now, but its all the same. But my phone does work with my friends wifi perfect... i wonder what the problem is a it just wont work with my Wifi..:(
     
  8. ventmore macrumors 6502a

    Joined:
    Jul 13, 2008
    #8
    I see. Your original post suggested that it was working at home but not whilst out and about.

    If it's working with other networks, but not your own, then it's more than likely down to the way you have your router set up.

    Is the DHCP server enabled on your router (not your phone)? If it isn't, then you'll need to either enable it, or set your phone to a static IP address.

    Do you have a password for your network? If so, you may not be entering it correctly into the phone.

    Do you have MAC filtering enabled in the router security settings?

    The best thing to do is first try switching your router off and then back on to see if that helps. If you still have problems, then you need to go in and disable any security settings you have set up. Remove any WPA or WEP encryption, and any MAC filtering. Also, make sure you are broadcasting your SSID (so that the router is visible to the phone).

    If you can find you can get a connection, then go through and enable one security measure at a time, checking each time that the phone can still connect.

    Let me know how you get on.
     

Share This Page