Setup solely by Screen Sharing

Discussion in 'Mac OS X Server, Xserve, and Networking' started by jw2002, Mar 3, 2010.

  1. jw2002 macrumors 6502

    Feb 23, 2008
    I don't have a USB keyboard to plug into my brand new mac mini Snow Leopard server box and don't want to go through the issues of pairing and unpairing my bluetooth keyboard. However, I do have a USB mouse. But with a mouse alone, I am still unable to get beyond the serial number entry page of the setup.

    I am able to see the new machine from my other mac but it requests a user and password when I attempt to connect via screen sharing. Is there a default password that works prior to the first setup of the Snow Leopard server? I tried a few variations like root/alpine but no dice. Also, unfortunately there doesn't appear to be a Character Viewer available during setup, otherwise I could at least limp through using the mouse for the very initial phases of setup far enough to enter serial numbers and get screen sharing configured to proceed with the full set up.

  2. jeroendh macrumors newbie

    Mar 3, 2010
    The way I used to remotely install, you'd need an usb keyboard and an usb dvd drive:

    1. Connect macmini server and a mac client to a router that uses DHCP.
    2. Restart the macmini, (with the dvd drive attached with the setup dvd in it) holding the C key.
    3. Startup Server Admin on the client, the server will show up there.
    4. Install your server

    I dont know if that works for you though. :)
  3. Alrescha macrumors 68020

    Jan 1, 2008
    Read the manual?

    You may want to read "Setting Up a Server Remotely", page 65 of "Mac OS X Server - Getting Started", which comes with the Mac Mini Server.

  4. jw2002 thread starter macrumors 6502

    Feb 23, 2008
    Thanks for the help. I installed the Server Admin suite on my mac and successfully performed the entire setup process for the server.
  5. jw2002 thread starter macrumors 6502

    Feb 23, 2008
    I found the problem. For packet traversal of things like ping and dns, NAT needs to be enabled ***along with*** the firewall in which a special firewall packet redirect rule is supplied by NAT in order to enable the subnet traversals. However, the firewall was defaulting to extremely restrictive and pretty much taking the Snow Leopard Server off the network, so I went in and allowed all traffic to all of the address groups. (No harm done since all of my subnets are behind a hardware firewall already). Thus I am now able to get DNS from my primary subnets onto the secondary subnets, and ping works fine.

Share This Page