sftp into ipod touch

Discussion in 'iPod touch Hacks' started by macsrck, Nov 15, 2007.

  1. macsrck macrumors newbie

    Joined:
    Oct 15, 2007
    #1
    i don't know if it is just me but after i tried updating to 1.1.2 with no success (computer's fault-won't recognize ipod after it downloads the new firmware but anywho) and when I try to sftp into my ipod now it pops up with an error saying

    Network Error: Connection Refused

    does anyone know whats wrong. thanks in advance

    P.S. i'm using WinSCP
     
  2. Reimer macrumors regular

    Reimer

    Joined:
    Sep 15, 2006
  3. ks-man macrumors 6502a

    Joined:
    Sep 25, 2007
    #3
    I'm having the same problem. I have installed both BSD Subsystem and Open SSH. I can see SSH on my springboard and it is set to on, but when I try to connect I get "connection refused."

    Anybody know how to fix this?
     
  4. sammyAD macrumors member

    Joined:
    Oct 16, 2007
    Location:
    England
    #4
    I just updated to jailbroken 1.1.2 this morning and i can't SSH either. im using cyber duck, have BSD and openSSH installed through installer.app but whenever i try and sftp access i get the following error:

    I/O Error: Connection failed
    <ip address>:22
    the KexTimeout (30000 ms) expired

    edit: i just tried upping the timeout limit to 60 seconds but i still get the same error except with 60000 ms
     
  5. ks-man macrumors 6502a

    Joined:
    Sep 25, 2007
    #5
    I finally succeeded in getting in.

    I did two things, not sure which one fixed it.

    1) I forgot my wireless network and re-connected to it
    2) I switched SSH to off, and then turned it back to on

    After doing these I connected with WinSCP. It first said that it had taken longer than 30 seconds and asked if I wanted to Abort, about 30 seconds later it finally connected to it.

    Hope this helps.
     
  6. sammyAD macrumors member

    Joined:
    Oct 16, 2007
    Location:
    England
    #6
    After some poking around i have also managed to get in - with a little help from ipodtouchfans (Q19)

    I also forgot my wireless network and re-entered my info
    closed iTunes
    set the timeout limit in cyberduck to 60 seconds
    browsed websites in safari on my touch while cyberduck was establishing an SSH connection

    and voila, SSH now working.
     
  7. Salvacion macrumors member

    Joined:
    Jul 28, 2008
    Location:
    Inglewood, CA
    #7
    I've tried all of the following as well as combinations of it and it still won't work, sometimes it will randomly work but there is nothing I can do consistently to make it work, I'm on 2.1 jailbroken with QuickPwn and before I was on 2.0.1 jailbroken with pwnagetool and I had no problems. Any thoughts?
     

Share This Page