Share drive on network but "read only" not working

Discussion in 'macOS' started by BigMacDummy, Dec 3, 2009.

  1. BigMacDummy macrumors newbie

    Joined:
    Dec 3, 2009
    #1
    Hi,

    Trying to share a drive on a small network of 4 Macs. G5 dual 2GHz PPC running 10.5.8 is set up to share the drive with "read only" privileges to other Macs on network. They are running latest versions of Leopard and Tiger. The "read only" option is not working and these users can "read & write"! Can this be fixed to "read only" that REALLY works by running Terminal and setting up their privileges in there and if so how. Thanks for any help in advance.....:confused:
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #2
    If the other Macs are connecting to the drive as an admin user then read only wouldn't apply. It could happen by default if the user that they use on their machine also exists and is an admin on the machine they are connecting to.

    Buuuuut I could be wrong on that...
     
  3. BigMacDummy thread starter macrumors newbie

    Joined:
    Dec 3, 2009
    #3
    The Mac sharing the drive is called G5 and has never had additional accounts. All guests are new accounts and have been added in the sharing window and given "read only" status but seem to have much more.......
     
  4. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #4
    I just checked in Snow Leopard.

    I enabled File Sharing on a host, and by default the Public folders are shared, and is set to read only for all but that specific user. When I used another SL machine, I clicked on the host share but didn't click "Connect As". It connected, and I could see the public folder but could not add anything except to the drop box.

    Then, I went back on the host, added the entire Macintosh HD to the share list, changed the persmission on "Admins" to read only (just in case, the main user on that machine can read/write).

    After going to the other machine and connecting back to that host (again, I didn't connect as guest or anything, just opened the share) and I could read all, but not write any files.
     
  5. BigMacDummy thread starter macrumors newbie

    Joined:
    Dec 3, 2009
    #5
    Thanks for that it sounds great but not sure if it works the same for Leopard? Can you confirm as I think I am unable to update a G5 PPC to Snow Leopard.
     
  6. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #6
    Unfortunately no, we've upgraded all of these machines to SL. However the settings are pretty much the same in Leopard, that's when it changed somewhat dramatically from Tiger.

    I would suggest manually resetting all of your share settings. Select all of the shares (in the sharing system preference) and click the the - button to remove them all and disable File Sharing. Then, take the "trusty ol' Windows approach" and restart your computer.

    Try my method in the above post, add the folder (or volume) you want to share after enabling sharing again, and make it read only for everyone but that specific user. Then have another computer connect to the host machine through the "Shared" sidebar in any Finder window. If the Shared pulldown doesn't exist (it was a problem in Leopard and maybe earlier where you could remove the whole shared section, you can't in SL) then you may need to restart or relaunch the Finder. That seems to be a random and potentially unfixable problem when I did the same thing.

    After I removed the the Shared section from the window,the only way I could access another computer was to go to the "Go" menu and "Connect" (which is a pain at first, but devices can then be bookmarked, and you can even make AppleScripts), but I digress.
     

Share This Page