share internet greyed out?

Discussion in 'Mac Basics and Help' started by klquinn, Aug 4, 2010.

  1. klquinn macrumors newbie

    Joined:
    Aug 4, 2010
    #1
    I am trying to share my ethernet/internet connection on a MacBook Pro through Preference> Share internet, but the check box is greyed out. I don't see a way to turn on additional ports as the errors message requests - and my firewall is disabled so all ports are on. Anyone have any ideas on what settings I have wrong?
     

    Attached Files:

  2. MCRunning macrumors 6502

    Joined:
    Sep 8, 2008
    #2
    Is that computer actively connected to the internet right now? If so you should have an option under "Share your internet connection from" Airport, firewire, ethernet, and bluetooth. Yours is showing no service available.
     
  3. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #3
    Are you currently using wireless internet on the MacBook? If so, that's the reason. Internet sharing requires you to have two physical connections.

    In other words, if you are connected to the internet using wireless, you'll need to connect the device you want to share the connection with to your ethernet port. If you want to share the connection wirelessly, you'll need to connect the MacBook to ethernet for internet.

    The same connection can't be used for both your access to the internet and to share with other devices.

    I hope that makes sense. :eek:
     
  4. klquinn thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #4
    I have an active functioning ethernet connect. I am not connected to a wireless network (there isn't one available - that's why I am trying to use my mac as one) I am trying to share my ethernet to airport so I can share my Mac's ethernet connection as wireless to connect an iPod touch.

    I cannot select the share my "ethernet" as "airport" because the Internet Sharing checkbox is greyed out.

    I think I follow Darth.Titan's post about needing 2 connections, but I have a co-worker that is doing exactly what I am trying... He only has an ethernet connection and is sharing it as airport - so folks can us him as a wireless hub. So the 2 connections didn't seem to be the case - at least for him?
     

    Attached Files:

  5. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #5
    Are you going through a corporate/school network ?
     
  6. klquinn thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #6
    I originally tried this through a work network - my co-worker can get it to work. I cannot.

    I also have tried at home - to test the 2 network connection theory. I have a ethernet connection AND wireless at home.

    Still seeing the same greyed out checkbox for internet sharing.
     
  7. klquinn thread starter macrumors newbie

    Joined:
    Aug 4, 2010
    #7
    Problem solved -

    Turned out to be a permission problem. Work had set up my account as an Admin, but not the Mac Admin - so I didn't have all the necessary read/write access to preferences files.

    To fix, I gave my account read/write access to the <harddrive>/Library/Preferences/System Configuration files

    I renamed the preferences.plist file and restarted my Mac to rebuild it.
    NOTE - you will have to reneter network connection info - so take notes or you can get it from the renames prefs file.

    upon restart I had access to Internet sharing - no more grey checkbox!

    It also cleared up some other weird things:
    The airport status menu bar icon wasn't functioning - no networks were listed and none of the menu items worked. Everything worked from the System prefs/network screen though... so had just been going there.

    Also the locations file from Apple icon/about my Mac/Network was empty and should have been full of all sorts of network connection info.

    This one was a weird on to troubleshoot - thanks for all that posted help!
     

Share This Page