iPhone Share via text problem

Discussion in 'Jailbreaks and iOS Hacks' started by stevey6404, Feb 27, 2013.

  1. stevey6404, Feb 27, 2013
    Last edited: Feb 27, 2013

    stevey6404 macrumors member

    Joined:
    Oct 7, 2010
    #1
    HI guys,

    Realised today that when I go to photo app, select a picture and share via text, the keyboard compresses and makes it look like I'm sharing on an iPhone 4 screen when it's an iPhone 5. Similarly, for share via FB, the keyboard is quite up while share via twitter the keyboard touches the bottom.

    Prior to jailbreak, this didn't happen so I'm unsure what cydia package to remove to fix this.

    Here are the pictures:

    http://dl.dropbox.com/u/43752843/IMG_3223.PNG
    http://dl.dropbox.com/u/43752843/IMG_3224.PNG

    Thanks in advance for any help
     
  2. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #2
    What tweaks do you have installed? Hard to say without a list. I am not aware of any tweak which causes this. Post a list and maybe we can get to the bottoms of it!
     
  3. darricksailo, Feb 27, 2013
    Last edited: Feb 28, 2013

    darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #3
    I have this problem too! It doesn't bother me much since i don't share stuff via email/text with an app often but I decided today to get to the bottom of this! Originally, I thought it was Auxo but after uninstalling that and the problem persisting, it doesn't seem to be Auxo.

    I manually disabled all mobile substrate tweaks via springtomize, problem persists
    I boot up holding volume up button to disable mobile substrate and the problem persists

    which is MIND BOGGLING. A non mobile substrate app shouldn't be affecting the keyboard like such.

    I proceeded to backup and all that stuff

    I DFU restore to new, set up iphone as new. problem fixed!
    I proceeded to restore from backup, problem still did not pop up

    I am in the process of restoring my iPhone 5 right now and jailbreaking it to see if the problem comes back. If it does, then it's the jailbreak itself causing the problem (probably by changing some .plist code stuff)

    If the problem is still not there, I am going to manually install each cydia tweak and check (time consuming but there's probably no other way). It seems it could be caused by a "dependency" if it isn't the jailbreak itself.

    I will keep you guys updated after I finish checking. Btw, what sources and tweaks do you have? What firmware is your iPhone 5 on?

    edit1: just finished restoring to iOS 6.1.2 and jailbroke! Typed something into the notes and chose to send via message and no problem yet. Going to try and see what happens after opening cydia for it to finish preparing the filesystem and respring.

    edit2: reopened cydia and let it download packages and downloaded the app YouTube and still no problem. Just turned off the device and turned it back on, still no problem yet.

    OH! AND I FORGOT TO MENTION THE FOLLOWING:
    And the weirdest part is that my friend's NOT JAILBROKEN iPhone 5 experiences the same problem! Given, she has jailbroken her iPhone 5 when it was iOS 6.0.2 or iOS 6.1 but i'm not sure what happened but her phone got messed up and she restored to iOS 6.1 and hasn't rejailbroken it. I do believe she did restore from backup. I restored my brand new phone from backup and the problem was gone so I doubt it was her backup causing the problem? My mom's friend's iPhone 5 on the other hand (never ever jailbroken) does not have this problem.

    edit3: just added all my sources and turned the iphone off and then on and tried again but no problems

    edit4: sbsettings and its dependencies installed, resprung and rebooted and problem not back (this is going to be a long post, isn't it? >.>)

    edit5: I AM BAFFLED. None of the tweaks cause this problem again! This leads me to believe it was a problem in a previous jailbreak that caused this (but this cannot be or else the problem would be much more widespread so probably it caused this with the bad jailbreak and a tweak?). The confusing part is that the backup didn't cause this problem like I thought it would have in this case. I forgot to jailbreak and then restore from backup and then see if the problem persisted. I don't feel like going through the route of restoring, rejailbreaking, redownloading all apps manually again. Sorry but it seems like I couldn't help you. I did not install auxo, just for your information.

    edit6: I think my friend only jailbreaked but didn't install any tweak; I will ask her to make certain
     
  4. stevey6404 thread starter macrumors member

    Joined:
    Oct 7, 2010
    #4
    My tweaks are:

    Activator
    AdBlocker
    Auxo
    GridTab for safari
    Infinifolders
    MapsOpener
    NCSettings
    NoDictation
    NoStoreButton
    PandoraDownloader
    SpotLock
    SwipeSelection
    WeeSearch Pro
    Zephy

    I'm running 6.1 firmware

    Thanks :)
     
  5. darricksailo, Mar 2, 2013
    Last edited: Mar 2, 2013

    darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #5
    Oops, forgot to respond to this thread.
    Well, so my friend only jailbroke but didn't install any tweaks. She is also on iOS 6.1

    Just now, I came upon a realization, I think this is an issue with iOS 6-6.1 itself?

    Now, we would need someone at 6.1 to test this. I'm on iOS 6.1.2 now and no more problems. I really don't think it's a tweak causing this since disabling mobile substrate completely doesn't fix this

    edit: actually, i'm not sure myself since i had this problem on ios 6.1.2 before and even restoring from the backup after a DFU restore did not bring the problem back. seems to be an issue that affects only a minority
     
  6. Jason B macrumors regular

    Joined:
    May 21, 2010
    #6
    I have this same issue on JB 6.1.2. Any other ideas? Don't want to restore
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    A workaround would be to have flex and install that patch that "fixes" the problem. No one knows the true cause behind this so there can't be a true fix to it.
     
  8. Jason B macrumors regular

    Joined:
    May 21, 2010
    #8
    Thanks. Would be nice if there was a "free" fix
     
  9. Jason B macrumors regular

    Joined:
    May 21, 2010
    #9
    Ok, found a FREE TWEAK. Screen extender from cydia. Follow these instructions to set it up. I just tested it and it works!!!

    http://forums.imore.com/jailbreaking-unlocking-hacks-themes-mods/253910-iphone-5-keyboard-out-place-too-high.html

    Scroll down to about halfway for the instructions.

    :)
     

Share This Page