Shared entire boot drive. Destroyed all permissions no longer boots.

Discussion in 'Mac OS X Server, Xserve, and Networking' started by velocityg4, May 24, 2010.

  1. velocityg4 macrumors 68040


    Dec 19, 2004
    The short of it is. I went into the sharing preferences in 10.5 Leopard and shared the boot drive. I then set the sharing settings to only allow the main user account and removed "administrators" and set the everyone option to read only.

    After doing so the hard drive turned into a folder with a stop sign on it. Then different programs started freezing and text started becoming garbled on screen. Apparently the sharing settings also effects folder and file permissions. While I thought it was just a separate entry stored by Mac OS X.

    Anyways I have booted off the install CD to try and repair permissions to no avail. As the boot drive is no longer recognized as one so there is no option to repair permissions. Is there any way to re-bless the System Folder so that repair permissions can be run? Or will I have to reinstall Mac OS X and wait 10+ hours for all the backups to be restored plus time needed to correct settings.

    If you are wondering why I did this. I was trying to give Windows in Parallels greater access to the files. As it seems to lose the connection to the shared folder screwing up access to my Outlook .pst files. They are stored on the Mac side to guarantee a back up as I am uncertain if the Parallels disk image gets backed up by Time Machine, after the initial backup.

    In Terminal through the install cd I have tried
    chown -R root:wheel *
    chmod -R 755 *
    to give full access back to root for the entire hard drive but Disk Utility still does not recognize it as a bootable drive to repair permissions on.
  2. Consultant macrumors G5


    Jun 27, 2007
  3. belvdr macrumors 603

    Aug 15, 2005
  4. velocityg4 thread starter macrumors 68040


    Dec 19, 2004
    This worked I didn't have time to wait for further responses. I'd think some warning message would pop up in the sharing pane saying this is a bad idea. As I would assume many have shared their boot drive before so they could get access to all files.

    Come to think of it I have done so before with no issues. Though this is the first time I bothered limiting access. As I recall in earlier versions of OS X you enabled sharing for a folder or volume in the Get Info dialogue.
  5. calderone macrumors 68040


    Aug 28, 2009
    For the record, it is root:admin and 775. Having dealt with this after a user removed "everyone" I have solved it before. I posted instructions here:

    You can still enable a shared folder through "Get Info." It still uses the standard permissions though, so sharing the entire drive and then changing the permissions is a recipe for disaster.

    My guess is that Apple doesn't expect people to share the entire drive and then further remove the standard permissions.

    If you don't understand the permissions or why they are there, don't touch them. In the case where I had to fix this, the user thought that if "everyone" had read only, that would apply to their home folder as well. Of course, this isn't the case.

    The best way to handle this is to leave the standard permissions and add an ACL. It would be a good idea for Apple to ignore standard POSIX permissions on locations like the Boot drive and /System.

Share This Page