Shared iTunes account - how to stop missed calls showing on both iPhone.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by theautopilot, Oct 5, 2016.

  1. theautopilot macrumors 6502a

    theautopilot

    Joined:
    Jul 27, 2010
    #1
    Hello helpful people :)

    My partner and I have iPhone which are linked to the same iTunes account. Since ios 9 (I think), any missed calls, and recent numbers, appear on both phones. This can get pretty confusing. Anyway to stop this, can't find anything in setting.

    TIA.
     
  2. i hate phones macrumors 6502a

    Joined:
    Jul 5, 2010
    Location:
    Philly Suburbs, PA
    #2
    I think you want to each have your own iCloud account- you can still log into the same iTunes account in the App Store and iTunes.
     
  3. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #3
    This is basically the better way of going about it.
    --- Post Merged, Oct 5, 2016 ---
    You can try disabling iCloud Drive in settings to see if that will do the trick. But the better way is what's mentioned above regarding separate iCloud accounts (while still sharing an iTunes one if that is desired).
     
  4. theautopilot thread starter macrumors 6502a

    theautopilot

    Joined:
    Jul 27, 2010
    #4
    That's great, I did not realize that you could have the same iTunes account but a different iCloud account. Will we still both be able to use apple music?
     
  5. i hate phones macrumors 6502a

    Joined:
    Jul 5, 2010
    Location:
    Philly Suburbs, PA
    #5
    That I'm not sure of, do you pay 9.99 for an individual sub or 14.99 for a family plan? I know family plan obviously works with multiple icloud accounts, not sure if there's away to get the individual one to work.
    --- Post Merged, Oct 5, 2016 ---
    Can you both simultaneously stream apple music now using the same account? or just one at a time?... I would try creating a new icloud for one of you and experimenting. in the iCloud settings, log into new account, but in iTunes and app store login to shared account. see if apple music works :)
     
  6. kaielement macrumors 65816

    Joined:
    Dec 16, 2010
    #6
    I sell phones for a living and this is one of the biggest problems we see. The main point is that Apple never designed iCloud to be used by multiple users. The key here is to have separate accounts. You can even have separate iTunes accounts and use family share to share things you buy from iTunes or the app store.
     
  7. JayJohnPaul, Oct 5, 2016
    Last edited: Oct 5, 2016

    JayJohnPaul macrumors regular

    JayJohnPaul

    Joined:
    Aug 13, 2014
    Location:
    Dawnbreak City
    #7
    ^THIS.

    I highly suggest making a new Apple ID, it literally takes less than 5 minutes and just use "Family Sharing" like @kaielement suggested.

    Anyway try this:

    Go to Settings > Phone > Calls on Other Devices make sure "Allow Calls on Other Devices" is turned off. Do this to every iDevices sharing the same account.

    Also make sure iCloud Drive is disabled.

    image.png
     

Share This Page