Shared printer is not visible to 3 other shared macs

Discussion in 'macOS' started by Sean Dempsey, Nov 3, 2008.

  1. Sean Dempsey macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #1
    I have my mac pro connected to my hp c3100 printer. It is shared, all sharing options are enabled on the Mac Pro.

    2 Macbooks and an iMac cannot find or see this printer. Networking, screensharing, file transfers, they all work fine. Just can't see the printer.

    Is AppleTalk required to do this? Here's some screenshots from the Mac Pro. I have never tried to network a printer in Leopard, I seem to remember it was easier in Tiger.
     

    Attached Files:

  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Do you have the print driver installed on the Macs trying to use your shared printer?
     
  3. Sean Dempsey thread starter macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #3
    No, but the printer doesn't even show up on any shared lists or anything. Don't the drivers usually get pulled over from the host computer?
     
  4. Sean Dempsey thread starter macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #4
    while searching for some help, I found my own thread on google... was hoping it was someone elses.

    Can someone tell me how OsX is supposed to share printers? I know I have done it before, so I am assuming that something is wrong. The printer is totally set up correctly on the server computer, but none of the other computers can add it through the printer system prefs. So obviously, something is wrong on the server that isn't letting it be seen.

    How can I go about troubleshooting this?
     
  5. kimwhite macrumors newbie

    Joined:
    Nov 11, 2008
    #5
    another problem that you have helped with before

    hi sean

    this is prob uncool to ask on a totally diff thread, but
    i have been scouring the net to find a remedy to my problem. and you seem to have some ideas.

    i have mac os 10.4.11

    you have answered a similar question in 2007.

    i have a zipped file (final cut pro) that i am trying to open and when i try to open it i get a "unable to unarchive (error 1 - operation not permitted)" message.
    i followed the guidelines you gave the other person i repaired permissions but when i tried to download onyx it told me the the onyx version needs a higher OS (10.5 i beleive) than i have and other efforts to find the onyx for my mac have failed.

    i have also downloaded x slimmer and Xserve raid driver for people that use final cut pro, i thought that this also might help

    can you please give me some help so i can start to play with final cut pro.

    thank you
     
  6. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #6
    hey sean, i currently do not share printers via my computers, i have the airport to do that.

    we need to know more information before we can answer your question. have you attempted to add the printers into your 'list' of printers? to do this, go into "print and fax" in system preferences.
    hit the "+" button to add a new printer, and have a search through there to see if it comes up.

    if not i would recommend uninstalling the printer from the macpro (or just hitting the "-" button in print and fax, and then restarting all computers and reinstalling and trying what i just suggested again.

    printers are shared mainly via bonjour, which would be enabled for you because of the shares that you have turned on. i dont know what the error is and i dont know why it isnt working for you.. it really is that simple!!

    hope i can help some how!
     

Share This Page