Shared Windows Printer Wont Print

SupadudeX

macrumors member
Original poster
Nov 7, 2006
94
0
I have a Brother DCP-7020 which is connected to my Windows XP machine via USB. I am trying to print to the printer with my Mac over my network. I got this working in Tiger by opening the printer setup utility, adding a printer, clicking on more printers while holding down the option key, selecting Windows printer via Samba, entering the information and selecting the driver. They seemed to have change the printer setup utility in leopard, however, and now it doesn't work. I can recognize the printer on the network through the new Print & Fax setup utility. I select the correct driver and everything seems good. When I try to print, however, I get NT_STATUS_CONNECTION_REFUSED.

Anyone else experienced this or know how to fix this? Thanks.
 

Caiwyn

macrumors member
Jan 24, 2005
84
0
Exact same problem here, using a Canon Pixma MP610. The printer is connected via USB to a Windows XP SP2 computer. I can set up the printer on the MacBook Pro (running Leopard) with no problems, but when I try to actually print I get NT_STATUS_CONNECTION_REFUSED. Anybody out there have any ideas?
 
Comment

simmmm

macrumors newbie
Oct 28, 2007
1
0
I have the same issue... When I was on Tiger I never had any problem like that. Nothing change on my PC configuration!
 
Comment

chrishenry

macrumors newbie
Oct 28, 2007
2
0
Hi,

I've managed to install SAMBA printer directly through CUPS. Go to http://localhost:631/ then click add printer, follow the on-screen instructions (choose Windows Printer via SAMBA for the device and enter the usual URI--smb://...--there is no need to include username/password apparently, Leopard asked me for that when I printed for the first time).

Hope that helps :)

chris
 
Comment

punter

macrumors 6502
Feb 22, 2003
265
0
Australia
Hi,

I've managed to install SAMBA printer directly through CUPS. Go to http://localhost:631/ then click add printer, follow the on-screen instructions (choose Windows Printer via SAMBA for the device and enter the usual URI--smb://...--there is no need to include username/password apparently, Leopard asked me for that when I printed for the first time).

Hope that helps :)

chris
hey that worked. thanks man! that was a crazy tip, port 631 on my own computer? who knew? thanks again
 
Comment

mmzplanet

macrumors regular
Nov 4, 2004
221
0
Florida
Hi,

I've managed to install SAMBA printer directly through CUPS. Go to http://localhost:631/ then click add printer, follow the on-screen instructions (choose Windows Printer via SAMBA for the device and enter the usual URI--smb://...--there is no need to include username/password apparently, Leopard asked me for that when I printed for the first time).

Hope that helps :)

chris
Outstanding tip there.... as the last poster said... I never knew. Go :apple:!
 
Comment

SupadudeX

macrumors member
Original poster
Nov 7, 2006
94
0
Has anyone gotten this working? If you have could you please post the URI that you used?
 
Comment

SupadudeX

macrumors member
Original poster
Nov 7, 2006
94
0
Ok I just got this working. I had to do smb://ipaddress/printer

Now I just need to figure out what to do with the ipaddress because my router assigns them dynamically.
 
Comment

redAPPLE

macrumors 68030
May 7, 2002
2,615
2
2 Much Infinite Loops
Hi,

I've managed to install SAMBA printer directly through CUPS. Go to http://localhost:631/ then click add printer, follow the on-screen instructions (choose Windows Printer via SAMBA for the device and enter the usual URI--smb://...--there is no need to include username/password apparently, Leopard asked me for that when I printed for the first time).

Hope that helps :)

chris
100 positive karma for you good sir.:D
 
Comment

gschoenthal

macrumors newbie
Nov 2, 2007
1
0
Ok I just got this working. I had to do smb://ipaddress/printer

Now I just need to figure out what to do with the ipaddress because my router assigns them dynamically.
I got this working also, but I would like to replace my printers IP address (actually it is the IP address of the computer that is sharing the printer) with the computers "Host Name".

i.e. instead of smb://192.168.11.61/hp_laserjet i would like to have smb://curie/hp_laserjet

Is this possible? Does not seem to work when I try it. Do I need to adjust a setting on the router?
 
Comment

WirelessInn

macrumors regular
Jun 20, 2007
107
0
New Mexico
Greetings:

I'll just throw in my 2c.
Forum participant "Camotec" at

http://discussions.apple.com/thread.jspa?messageID=5852413

has also provided a solution to the printing difficulties encountered under Leopard, especially to shared printers connected to another machine (Windows) on a network.

Here is his advice/step by step - worked for me, finally!


"Hey guys,

I have the solution for you.

Prerequisites: 1. your windows PC with the printer on it needs to have an admin account on it with a single word no spaces. (preferred unix) 2. your printer sharename is a single word (ie. Canon iP4300 should be just ip4300).

Now follow the below steps:

1. Open your system preferences > Open Print & Fax
2. Click + to add a printer.
3. Right-click on the Toolbar at the top and select "Customise Toolbar..."
4. Drag the "Advanced" icon to the toolbar & select "Done"
5. Click the "Advanced" icon
6. Select "Windows" from the "Type:" drop down menu
7. In the "URL:" textbox type the location of your windows printer in the format below (use the format depending on whether your Windows PC sharing the Printer has a password or not):
smb://username:password@ipaddress/printersharename <- Print Server does have a password
smb://username@ipaddress/printersharename <- Print Server does NOT have a password
(eg. smb://barney@125.254.95.101/ip4300)
8. Enter a Name and Location. (Human Friendly Names with Spaces are allowed)
9. Now select the appropriate driver and then click "Add"
10. Try printing somthing and then it will ask for a username and password of your windows server. Type and username and then the password and then add this to your keychain and click OK.

And there you go. Printing in OSX 10.5

Cheers
Ben Camilleri
Camotec Web Solutions
ben@camotec.com.au+
http://www.camotec.com.au "


Now, of course, i have to figure out how to point my MBP to a shared printer located on another - Win - machine on the network, WITH A DHCP, dynamic IP assigned.

- Roger T
 
Comment

Crimsonibis

macrumors newbie
Jan 16, 2008
2
0
DCP-7020 seen by OSX after rename

I've been plagued with the problem of OSX not being able to see the shared Brother DCP-7020 printer connected to a Windows desktop. Like other members above it worked well once and then stopped. I thought there was a problem on the PC end so I added the printer again and changed the share name. With the newly added (and shared) printer on the PC, OSX still couldn't see it in the printer setup utility. Then I tried something that was ridiculously simple that it worked. The shared printer's name was separated by a space and consisted of 13 characters. I dropped the name to 6 characters, eliminated the space and instantly OSX saw the printer. I added it, and wireless printing has been restored.
 
Comment

archonium

macrumors newbie
Nov 29, 2007
24
3
I added the printer successfully.

Problem is when I print anything, the printer responds but print's nothing. It just keeps feeding paper through it.

Driver problem?
 
Comment

Zebceponaf

macrumors newbie
Feb 1, 2008
14
0
alright I'm going to apologize for being a complete n00b at networkign ahead of time, but this seems like the closet's I've been to by printer through xp pc sharing.

can someone help out? I've no idea what to put in the URI: field.

cheers
 
Comment

Zebceponaf

macrumors newbie
Feb 1, 2008
14
0
printer ip address

where do I find this in xp? Is this only if you have your printer connected to a print server? what if it's connected directly to pc?
 
Comment

VTSkier

macrumors newbie
Feb 5, 2008
1
0
Printing from Leopard to Windows

I had the same problem with an HP and an Epson both connected to Vista

Try this:

Go to System Preferences|Network|Advanced.

From there select the WINS tab.

You not only have to enter the Workgroup name (workgroup in my case) you also have to enter the IP address of the printer server [host] PC on the next line, under WINS Server (10.0.1.198 in my case.)

As soon as I added the IP address and saved the update I could print just fine!

Hope this works for you.
 
Comment

ibelee

macrumors newbie
Jun 20, 2009
2
0
I've been plagued with the problem of OSX not being able to see the shared Brother DCP-7020 printer connected to a Windows desktop. Like other members above it worked well once and then stopped. I thought there was a problem on the PC end so I added the printer again and changed the share name. With the newly added (and shared) printer on the PC, OSX still couldn't see it in the printer setup utility. Then I tried something that was ridiculously simple that it worked. The shared printer's name was separated by a space and consisted of 13 characters. I dropped the name to 6 characters, eliminated the space and instantly OSX saw the printer. I added it, and wireless printing has been restored.
YOU ARE A GENIUS!!! i've tried so many fixes in so many configurations, and THIS was the fix....may you live long and prosper !! thank you, thank you, thank you!:D
 
Comment

Mini Cooper

macrumors newbie
Aug 11, 2009
14
0
Sunny Scotland
I had the same problem with an HP and an Epson both connected to Vista

Try this:

Go to System Preferences|Network|Advanced.

From there select the WINS tab.

You not only have to enter the Workgroup name (workgroup in my case) you also have to enter the IP address of the printer server [host] PC on the next line, under WINS Server (10.0.1.198 in my case.)

As soon as I added the IP address and saved the update I could print just fine!

Hope this works for you.
Well you have managed to get me on a bit with this. I did the above and the printer came up but when I try to print to it, it reports unable to connect to printer. Anything else I should be doing?

Thanks....
 
Comment

Mini Cooper

macrumors newbie
Aug 11, 2009
14
0
Sunny Scotland
Greetings:

I'll just throw in my 2c.
Forum participant "Camotec" at

http://discussions.apple.com/thread.jspa?messageID=5852413

has also provided a solution to the printing difficulties encountered under Leopard, especially to shared printers connected to another machine (Windows) on a network.

Here is his advice/step by step - worked for me, finally!


"Hey guys,

I have the solution for you.

Prerequisites: 1. your windows PC with the printer on it needs to have an admin account on it with a single word no spaces. (preferred unix) 2. your printer sharename is a single word (ie. Canon iP4300 should be just ip4300).

Now follow the below steps:

1. Open your system preferences > Open Print & Fax
2. Click + to add a printer.
3. Right-click on the Toolbar at the top and select "Customise Toolbar..."
4. Drag the "Advanced" icon to the toolbar & select "Done"
5. Click the "Advanced" icon
6. Select "Windows" from the "Type:" drop down menu
7. In the "URL:" textbox type the location of your windows printer in the format below (use the format depending on whether your Windows PC sharing the Printer has a password or not):
smb://username:password@ipaddress/printersharename <- Print Server does have a password
smb://username@ipaddress/printersharename <- Print Server does NOT have a password
(eg. smb://barney@125.254.95.101/ip4300)
8. Enter a Name and Location. (Human Friendly Names with Spaces are allowed)
9. Now select the appropriate driver and then click "Add"
10. Try printing somthing and then it will ask for a username and password of your windows server. Type and username and then the password and then add this to your keychain and click OK.

And there you go. Printing in OSX 10.5

Cheers
Ben Camilleri
Camotec Web Solutions
ben@camotec.com.au+
http://www.camotec.com.au "


Now, of course, i have to figure out how to point my MBP to a shared printer located on another - Win - machine on the network, WITH A DHCP, dynamic IP assigned.

- Roger T


Further to my previous post.....

This one works, no problem at all. Thanks SO much to WirelessInn for posting. I've been at this for about 3 weeks now.

THANKS :D
 
Comment

vlyon

macrumors newbie
Dec 23, 2011
1
0
need more hand-holding printer stopped working

I have been using my mac with my home network. Macbook pro. Trendnet router. PC with Brother printer attached.
It's worked fine for a year.
Suddenly lately whenever I try to print I get "NT_STATUS_CONNECTION_REFUSED"
I can use finder to look at my PC. I can save from the macbook to the PC.
I can print from the PC. I can no longer print from the mac.

I see the advice above but I have no idea how to find the location of my windows printer so I'm stumped.

Oh, I have an HP printer attached to the PC. It also can't be used from the macbook (although in both cases the macbook will tell me the status of the printer).
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.