sharing a linux printer --how?

Discussion in 'macOS' started by BiPolar, Aug 17, 2005.

  1. BiPolar macrumors member

    Oct 5, 2003
    My wife has a g3 running osX, I've got a pc running Fedora Core 4. I have the printer plugged into my linux box and it is shared (i know this because my laptop, running XP can use it).

    How do I set up the mac to use the printer? I tried IP printing and put the print-queue name in, but nothing happens.

    LIttle help?
  2. cbiffle macrumors member

    Jun 19, 2005
    Tempe, AZ
    You'll have to make the printer available for sharing, of course.

    Fedora should use CUPS by default (at least, mine does). You can try to use its handy-dandy Printer Setup thingy, but in my experience, it will fail you about half the time. If you point a web browser at http://localhost:631/ you should get a configurator that will serve you well.

    Since you're a Linux user anyway, I'll RTFM you and point you at Google. :) If you google around for 'CUPS sharing printer' you should have some worthwhile hits. The CUPS manual itself contains documentation on this.

    If you get the printer shared for IPP (CUPS's native protocol), what you did on the Mac should work fine.

    Of course, if you've already done all this, remind me that I'm an idiot. :)
  3. belvdr macrumors 603

    Aug 15, 2005
    No longer logging into MR
    If your XP box can print to it, I assume you're using SMB. This also means that permissions should be correct. You also want to make sure your G3 is in the same workgroup as the Linux server and XP box. You can do this through Directory Acceess in Applications / Utilities.

    I believe you can hold down Option when clicking Add in Printer Setup, and it will give you more options for connecting to a network printer.
  4. BiPolar thread starter macrumors member

    Oct 5, 2003
    yes, i am sharing via smb, but the option doesn't seem to give me any more choices.

    i put my ip address of my linux box in, and then i've tried both saying use default queue and putting in my specific queue name. neither print. although, now i can't delete the default-made one, it just says printing...and that's even after a restart.

    am i missing something? i don't think it's an iptable/firewall issue because i can access the drives on the machine from the mac. however, the issue might be the print driver (it's a canon i860...i'm using turboprint to print from linux) but when I try and set up the print from the mac and it asks me what driver, i can't select the installed driver on the mac. argh.

    shouldn't this be easier than sharing the printer to a pc? I mean, they're both unix-based!

Share This Page