Sharing and Permissions lock out

Discussion in 'MacBook Pro' started by Edfs, Mar 25, 2013.

  1. Edfs macrumors newbie

    Joined:
    Mar 25, 2013
    #1
    My bad. Without thinking I put in a "no Access" for Everyone on my HD get info.
    when I boot up My macbook pro won't even get pass the apple logo and just keep on spinning.
    I use the terminal to chmod but it's a read only access. Tried sudo chmod,chflags and failed each time.Pls help. I'm into my 4th hour of continued desperation.
    Thanks in advance for every bit of advice you can spare.
    BTW, I'm not a frequent command line user.
    Edfs
     
  2. justperry, Mar 25, 2013
    Last edited: Mar 25, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Start up in recovery mode by holding Command-R, then choose recovery, when you arrive in the recovery screen go to the menu Bar and open Disk Utility, click on you Macintosh HD and repair permissions, this might solve the problem but it might not since it should have permissions to read from the receipts folder on that HD.

    There is also a way to do this in Single User mode but is a bit complicated, you have to mount the disk and set the permissions on the whole disk with chmod ugo.

    Edit: If the first one does not work, startup in Single User Mode, then add the following commands:

    fsck -y
    mount -uw /
    sudo chmod ugo rwx

    If this works you then have to Open Disk Utility and repair permission, you also have to repair User permissions which are NOT fixed by this and you again have to do this from Recovery, the process is a bit different and I forgot exactly how.
    BUT, I would backup most of it later on and start with a new install since your permissions are all over the place and for security reasons it is better to do a clean install and import from a backup.
     
  3. Edfs thread starter macrumors newbie

    Joined:
    Mar 25, 2013
    #3
    Thank you. I will try your recommendation tomorrow and let you know the result.

    Thank you. I shall give it a try tomorrow and let you know the result.
    Edfs
     
  4. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    I actually did find out how to repair Users Home Folder permissions.
    You have to startup in recovery, then open Terminal, enter reset password, the reset Password Utility appear, then click on the HD and in the tab below choose the User to reset, last step is to reset in the lowest part of the utility, when finished restart.

    Hope it works out, and never make that mistake again.:p
     
  5. Edfs thread starter macrumors newbie

    Joined:
    Mar 25, 2013
    #5
    Success!

    Thank you JustPerry.
    I tried the single user mode with
    Fsck -y
    mount -uw /
    but the ugo rxw didn't work so I tried
    chmod u+rwx,g+rwx,o+rwx .
    then
    chflags nouchg . (. being my root)
    ls -lo
    cross my fingers and exited
    and it restarted and work!
    Thanks again and now I'm backing up.
    Learned my lesson the hard way. But just out of curiosity, why would "Everyone" in the get info include me, the user and admin?? I thought it
    meant "Everyone else EXCLUDING me who is invoking the no access to MY HD.
    And once you do that No Access on everyone, you are toast.No password no nothing!no 2nd chance and definitely NO Soup for you!
    Thanks again Justperry.
     

Share This Page