Sharing connection through Airport.

Discussion in 'MacBook Pro' started by Selarmor, Jan 12, 2008.

  1. Selarmor macrumors newbie

    Joined:
    Jan 12, 2008
    #1
    I'll apologize ahead of time as I know this has been posted countless times, but I honestly think I've read every thread on this subject and still can't find a solution that works.

    I received an Xbox 360 and the official wireless adapter for Christmas. I'm now back at college and trying to connect to the Internet by sharing my connection through Airport, but I keep failing the IP address test.

    There's no router involved in this. In my dorm room the ethernet cable goes from the wall to my MacBook Pro, and it's this connection I'm trying to share. Internet sharing is on and I've turned the firewall off.

    My 360 can find my network and connect to it, but that's as far as it goes. The odd thing is I also have a Wii and sharing my connection to it works flawlessly. I've seen dozens of topics suggesting entering all kinds of info manually, but nothing has worked and honestly I don't feel I should have to enter any information manually since the Wii is able to connect automatically.

    After the IP address test fails this is the information that the 360 obtained automatically (which doesn't work):

    IP Address: 169.254.17.82
    Subnet Mask: 255.255.0.0
    Gateway: 0.0.0.0

    And this if the information in "Network" under system preferences:

    IP Address: 128.180.211.58
    Subnet Mask: 255.255.252.0
    Router: 128.180.211.254

    I don't quite understand how a software company can't get this to work smoothly while Nintendo can (assuming it's not my error), but I've been trying for hours and hope someone knows the solution.

    Thanks for reading all that.

    Edit: Love the MacBook Pro btw, first Mac and not going back.
     
  2. brizobst macrumors newbie

    Joined:
    Feb 21, 2008
    #2
    sorry i can't help but...

    i'm trying to connect my wii (which apparently you had no problems doing). I've also seen several threads about entering things manually but nothing has worked. Could you walk me through how you set up your wii through internet sharing? thanks...
     
  3. hardsc02 macrumors member

    Joined:
    Feb 20, 2008
    #3
    Try manually typing in the IP address of your Airport into the 360 settings under network. I've had a similar problem with 360 Live before and doing made it work.
     
  4. Selarmor thread starter macrumors newbie

    Joined:
    Jan 12, 2008
    #4
    Sure. The first thing you need to do is go to your firewall and create a new port. Select "Other" as the name and put something like "Nintendo Wi-Fi" as the description so that it's easily recognizable. Under "TCP Port Numbers(s)" put the following numbers separated by a comma and space as such:

    28910, 29900, 29901, 29920, 80, 443

    I think turning on personal web sharing enables ports 80 and 443, so if you have that on you only need the first four numbers.

    Now go to the Internet tab and select "Built-in Ethernet" from the drop down box and then check "AirPort". Go to "AirPort Options...", select a network name, choose "Automatic" as your channel, and if you want security enter a 5 or 13 character password for 40 and 128 bit encryption, respectively. Now start Internet sharing.

    On the Wii settings menu, go to Inernet, Connection Settings, Connection 1 (or any open connection), Wireless Connection, and then search for an access point. You shared connection should show up, so select it, enter a password if necessary, and follow the steps to be online.

    Edit:
    Turns out I didn't read quite everything on this subject. I just found out that the problem was a bug on Apple's side. I edited a value using NetInfo Manager and now the 360 connects automatically without any problems.

    For those interested, the solution is here.
     

Share This Page