Sharing External Hard Drive and not getting the correct permissions

Discussion in 'macOS' started by kjchung, Jan 11, 2010.

  1. kjchung macrumors newbie

    Joined:
    Jan 11, 2010
    #1
    So this is my situation.

    I am using a mac mini running snow leopard as my file server. I have a drobo attached to the mac mini via firewire 800. The drobo has been formatted to Mac OS Extended Journaled. I created a bunch of folders on the drobo which I want to share out to my other Mac systems and two windows computers.

    I have a folder called Software, TV, Movies, and Public. I have SMB enabled with user accounts. On the windows computers once I input my the username and password I have no problems seeing the shared folders. The problem I am having is lets say on the software folder i set the permissions on User1 to have read only access. Well on the windows computer it seems to have full access. I can delete create etc. This goes for any shared folder. No matter what permission I set the windows computer will always have full access to the folder.

    I have made sure that the guest account has no access and still this seems to be a problem. As a test I connected a generic USB external hard drive (mac formated) and created the same set of permissions and I get the same result.

    The catch to this problem is if I create a share on the internal drive of the mac mini with read only permissions then the windows computer will only have read only access.

    I just switched over from PC to Mac about a year ago and I love it but I'm wondering am I missing something on on getting my drobo to have proper permissions for windows users? Thank you in advance for any suggestions.
     
  2. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #2
    Let me get some clarification.

    On the Windows computer you are entering User1 as username and whatever password you created for that user, and still getting full access?

    When you set your access limits, were you logged in as an administrator? Is User1 set as an Administrator on the mini? If so, set them as a user only.

    Double check your permissions settings, and under them in the Get Info window for that folder there is a Gear with a drop down, select 'Apply to all' or something like that, then confirm it.

    Try again,

    Reply back if you still have issues.
     
  3. kjchung thread starter macrumors newbie

    Joined:
    Jan 11, 2010
    #3
    thanks for a response. Yes on the windows computer I log on using the same username and password created on the mac mini. User1 only has read only access on the mac mini and is not an administrator. The strange part is the permissions seem to work when the share is on the internal drive. If the share is on the external drive (drobo or any other external HD) the permissions are ignored and that account has full access. I thought it had something to do with external drives. I find it quite strange and not sure what other settings I should change. Thanks again for your help.
     
  4. bmcgonag macrumors 65816

    bmcgonag

    Joined:
    Mar 20, 2007
    Location:
    Texas
    #4
    That is a strange situation, sorry I couldn't be more help, but I'll keep an eye out, and if I come across anything, I'll reply back.

    Best,

    Brian
     
  5. Robocopper macrumors newbie

    Joined:
    Dec 31, 2009
    #5
    Funny you should mention this weird behavior because I recently went thru the same process and came to the same conclusion.

    But is it really possible that Apple could have stuffed up this badly? I mean, this is just basic disk permissions and should have been debugged long ago!

    So anyway, did you managed to go any further and get it working? I have a Mac Mini with 10.6.2 and want to use it as a file server as well as a machine for the lounge, and then use a few Seagate FreeAgent Go drives to serve files and since they have a iPod style dock, I can remove one and leave it in a safe.
     
  6. fuzzy76 macrumors newbie

    Joined:
    Apr 24, 2008
    Location:
    Tromsø, Norway
    #6
    #winning

    Found the solution for this. You have to open up the properties for the drive and deselect "ignore ownership for this volume" at the bottom. Apparently, it causes OS X to ignore all permission restrictions.

    I would have thought it did not have anything to do with share permissions, but it does.
     
  7. Robocopper macrumors newbie

    Joined:
    Dec 31, 2009
    #7
    Reply to Fuzzy

    Hey Fuzzy, I think that ticking the box you mention also allows everyone on the network to also access the files. e.g. all security is removed.
     

Share This Page