Sharing Mac internet with PS3 via Linksys router

mohalfares

macrumors newbie
Original poster
Sep 17, 2009
25
0
Hi,

I've a Macbook, PS3 and Linksys ADSL Gateway that can be put in Bridge Mode.

Macbook is connected to the internet via 3G USB modem.

I was able to tell Macbook to broadcast it's 3G internet connection via AirPort and use it from any other Machine, such as iPhone.

But the problem here, is that I want can't use it in my PS3, because it's the old 20GB model which doesn't have a wireless connectivity.

So, I figured out that I might be able to tell Macbook, to share it's 3G internet connection with the Linksys ADSL gateway while it's out in Bridge Mode, and this gateway can send the internet connection to PS3, all using Ethernet cables, as follows:

Macbook --> Linksys ADSL gateway in Bridge Mode --> PS3

But I couldn't make it work.

This is what I've done so far:

1- I plugged the Ethernet cable from Mac to Linksys ADSL gateway
2- I put Linksys ADSL gateway in Bridge Mode
3- I plugged another Ethernet cable from Linksys ADSL gateway to PS3
4- I went to network preferences in Mac and choose the Manual settings
5- I gave the Mac the IP address: 192.168.1.101, Subnetmask: 255.255.255.0, Router: 192.168.1.1 and DNS: 192.168.1.1
6- I went to to PS3 wired settings and gave it IP: 192.168.1.102, same setting with other fields as Mac Ethernet
7- While testing the connection in PS3, the IP check went successfully, and the internet didn't

Note: I do not want to connect Mac to PS3 directly via a croseeover cable because I want to share the internet connection in mac with Xbox 360 as well, which also doesn't have a Wireless connectivity.

Thanks
 

mohalfares

macrumors newbie
Original poster
Sep 17, 2009
25
0
Ok, after so many googling, I just found the solution:

The DHCP won't work. You have to configure both Mac and PS3 manually:

Give the Ethernet in Mac the following IP number: 192.168.1.101, and Subnet Mask: 255.255.255.0. No router or DNS server info, leave them blank

Now share this Ethernet connectivity from Sharing section.

Go now to PS3, and give it a manual settings:

IP: 192.168.1.102
Subnet Mask: 255.255.255.0
Router: 192.168.1.101
Primary DNS: Enter your IP that you can get from http://www.ip2location.com
Secondary DNS: Get it from (About this Mac) -> More info -> Network -> then click on the 3G connection chipset name you're using -> Looks at DNS -> Server Addresses -> take the first number, and this the secondary DNS. Notice there is another number next to it, just ignore it

And that's it, everything will work just fine now :D
 
Comment

biddom

macrumors newbie
Nov 24, 2010
1
0
Help

Hi and thanks for your instructions.
Worked great for some weeks!
But now Im back on square one :(
Dont know why, any suggestions?
 
Comment

Similar threads

  • dianett
14
Replies
14
Views
548
  • super_kev
9
Replies
9
Views
854
Replies
7
Views
807
  • Multicopy
0
Replies
0
Views
322
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.