Sharing NTFS USB drive from Mac

Discussion in 'macOS' started by ignign0kt, Jan 3, 2012.

  1. ignign0kt macrumors member

    Jun 13, 2010
    I have a USB NTFS drive hooked up to my Mac Mini. I want to share it on the network so my MBP can write to the USB drive. When I share the drive in OSX, the Users box is grayed out, so I can't add users or change permissions.
    I can connect to it from my MBP but I can't write files without permissions
    I tried AFP and SMB.
    Is the problem the NTFS or the fact that it's a USB drive?

    Any other way I could write to it from the network?
  2. GGJstudios macrumors Westmere


    May 16, 2008
    NTFS (Windows NT File System)
    • Read/Write NTFS from native Windows.
    • Read only NTFS from native Mac OS X
      [*]To Read/Write/Format NTFS from Mac OS X, here are some alternatives:
      • For Mac OS X 10.4 or later (32 or 64-bit), install Paragon (approx $20) (Best Choice for Lion)
      • For 32-bit Mac OS X, install NTFS-3G for Mac OS X (free) (does not work in 64-bit mode)
      • For 64-bit Snow Leopard, read this: MacFUSE for 64-bit Snow Leopard
      • Some have reported problems using Tuxera (approx $36).
      • Native NTFS support can be enabled in Snow Leopard and Lion, but is not advisable, due to instability.
    • AirPort Extreme (802.11n) and Time Capsule do not support NTFS
    • Maximum file size: 16 TB
    • Maximum volume size: 256TB
    • You can use this format if you routinely share a drive with multiple Windows systems.
  3. ignign0kt thread starter macrumors member

    Jun 13, 2010
    I do use Paragon.
    But I'm looking for a way to share it on the network for write access
  4. simsaladimbamba

    Nov 28, 2010
    Tried this yet? It might not work due to it being NTFS.

  5. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
  6. ignign0kt thread starter macrumors member

    Jun 13, 2010
    There's nothing there under the Info window

    However I got OSX to share the drive with full permissions
    And I can see the share from my MBP
    But when I try to open the folder I get this error: (the folder is called Movies)

    The operation can’t be completed because the original item for “Movies” can’t be found.

    As for using exFAT. I have no way of saving the files that are currently on the hard drive for me to format it
  7. nashhaq macrumors newbie

    Jun 10, 2012
    Still No Luck


    I have the same exact problem. I bought a mac mini server (Mid 2011) to use as a media server to be hooked up on a network. I was previously using a windows based PC so my Raid array was formatted as NTFS.

    I use Paragon NTFS to read/write NTFS.

    I have been at it for a year now, and i still have not been able to share a NTFS drive from Lion OS X. Its pretty frustrating! Whenever i share a NTFS folder from my mac , it seems to break SMB. I can assign users, permissions to the share but i cant access them from a windows pc with SMB. Lion also broke SMB and apparently 10.7.4 fixes a number of issues but it still does not let you share NTFS folders from your mac. If a NTFS folder is shared, the remote user will not be able to get to ANY of the shares, doesnt matter if they are HFS+ or not.

    Have you had any luck with the issue.
  8. blazinbear82 macrumors newbie

    Jun 16, 2012
    damn i was trying to do the same im new to mac but its fairly easy to use i been at it for about 2 weeks running textura for my ntfs drives .... and trying to share them on windows 7 since im using a hackintosh.. added permissions but no luck.. but i was able to share the mac os drive just fine since its not ntfs... go figuere. let me know if you guys come up with a solution.
  9. tinymiata macrumors newbie


    Mar 21, 2011
    I was going nuts trying to fix this as it worked perfect in 10.6.
    I found a post with this info.
    the reason why you can't share your NTFS drive from OSX to Windows: In OSX Lion Apple replaced the open source samba with apples own version which unfortunately ignores anything that isn't hpfs. So it hasn't anything to do with your drivers or such.

    As such I found this script that replaced apples samba.

    I now have the nice control over what is shared ntfs exfat hfs to what groups etc.

Share This Page