"Sharing Only" User Account - SSH?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Cuyahoga, Feb 20, 2009.

  1. Cuyahoga macrumors member

    Cuyahoga

    Joined:
    Jun 12, 2007
    #1
    I was wondering if Leopard's "sharing only" user account class works with SSH ("remote login") instead of just AFP/Samba? I've read all of Apple's docs and they are ambiguous about this fact (though I'd say leaning towards AFP-only).

    Thanks for your help!
     
  2. macnewbey macrumors newbie

    Joined:
    Mar 17, 2009
    #2
    Hi!

    See this article:
    http://www.macworld.com/article/132002/2008/02/mobilemac2503.html

    You can create Sharing Only users in the Accounts preference pane by creating a new account and selecting Sharing Only from the New Account drop-down menu. You can also create a new Sharing Only user from the File Sharing pane by clicking on the plus button under the Users list; by default, that new user will be granted Sharing Only privileges. (Sharing Only users can access remote volumes only via Apple Filing Protocol [AFP], not FTP or Samba.)

    So it appears that for now, "Sharing Only" user does not support SMB :mad:
     
  3. myjay610 macrumors regular

    Joined:
    Jan 6, 2008
    #3
    Did you try it? I have before, but didn't work. I had to make a regular user to SSH in.
     
  4. macnewbey macrumors newbie

    Joined:
    Mar 17, 2009
    #4
    I tried Sharing Only user but it didn't work. Finally I had to create a standard user and assign permissions.

    So as the article says, Windows to MAC access is possible only through a user account that has login rights (and a Sharing Only user has no login rights).
     
  5. clancyhood macrumors newbie

    Joined:
    May 27, 2011
    #5
    Possible in Snow Leopard, BUT...

    Simply create the user, set to "sharing only", accept the changes, then command-click the user in Accounts preference pane, choose "advanced options", and change "login shell" to "/bin/bash".

    Note that the privileges of this user seem fairly widespread - from the terminal at a nearby Ubuntu box I logged in and I tried a few things, and was even able to delete files that belonged to me (me as in GUI me, not to the "sharing only" user) - I was merely prompted "override rw-r-r clancy staff for [file]? y/n".

    dseditgroup admin yields myself and root as members, not the new user. Not sure why he's so damn powerful, but perhaps this is why default shell is none!

    Clancy
     

Share This Page