Sharing - Only working one way - Help please

Discussion in 'Mac Basics and Help' started by youngestchild, Jun 9, 2008.

  1. youngestchild macrumors regular

    Joined:
    Feb 22, 2005
    Location:
    sydney
    #1
    Hello. I have an iMac and mac pro. The are both currently working under these same setups:

    10.5.3
    File sharing on for File, Printer, Web.
    Security - Firewall set to 'set access for specific services and apps" (file, printer, web showing here)
    iTunes sharing setup and working, both computers can see and play each others library.

    here's the thing that sticks... the imac can happily connect to the mac pro, from the imac you can check out all the files and programs as if you were working directly on the mac pro - to access the mac pro from the imac you simply click on the mac pro icon in finder and the net auth asks for keychain password and yr away.

    BUT the mac pro can not connect to the imac. when i click on the imac icon in the mac pro finer it starts 'connecting' and then after a minute or two it fails.

    the really annoying thing is that i set this all up and it was working and now its not!

    anyone suggest anything at all?! :confused:

    thanks
     
  2. motulist macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #2
    Are you trying to do this in a complicated networking environment? When I tried to use file sharing between two computers connected via ethernet at the same time as my internet connection was going over the same ethernet cable also, I had problems that sound very similar to what you're having.
     
  3. youngestchild thread starter macrumors regular

    Joined:
    Feb 22, 2005
    Location:
    sydney
    #3
    it works now... just don't ask me how.

    I'm doing this over an airport express.... the AE is connected to a modem (via ethernet) and my receiver speakers for airtunes. Both the imac and mac pro connect to this via a wireless network i created. Before we bought the mac pro we had the ibook connected to the same network but only running 10.4.7 so the file sharing had its glitches but I wasn't all that concerned because of the OS difference. But now everything is even i want it to 'just work'.

    ah... so I had screen sharing on while on the imac and connected to the mac pros screen... while on the mac pro screen i clicked screen sharing w/ the imac (don't do this if yr easily tripped out) and that worked. To quit out of this weird trippy loop i could only do it by physically going to the mac pro and quiting screen sharing soooooo i thought, what the hell, while i'm here i'll try connecting to the imac again .... and it works now. :confused:

    but i still don't know why. if anyone can understand this i'd still be really happy for them to explain what is going on. cos no doubt i'll come across this again :(
     

Share This Page