Sharing & Permissions question

Discussion in 'Mac OS X Lion (10.7)' started by kirkbross, Jul 12, 2012.

  1. kirkbross, Jul 12, 2012
    Last edited: Jul 12, 2012

    kirkbross macrumors 6502a


    Mar 6, 2007
    Los Angeles
    I was messing around with folder permissions trying to make some folder available to some users and not others on my Mac Pro running Lion.

    In the list with Name and Privilege, I ended up with two "everyone" Read & Writes and can't delete either one because the minus sign is grayed out. How do I delete one or reset it to it's original defaults and start again?

    Question 2: do I need the 'everyone' user in this area?
  2. Alameda macrumors 6502a


    Jun 22, 2012
    First step would be to run Disk Utility and Repair Permissions.
  3. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    I did some poking around in my files and found the all add Everyone entries, some were read only and some were no access. It all depends on what you want for access permissions.
  4. GGJstudios macrumors Westmere


    May 16, 2008
    Some people repair, or recommend repairing permissions for situations where it isn't appropriate. Repairing permissions only addresses very specific issues. It is not a "cure all" or a general performance enhancer, and doesn't need to be done on a regular basis. It also doesn't address permissions problems with your files or 3rd party apps.

    Five Mac maintenance myths
    There are times when repairing permissions is appropriate. To do so, here are the instructions:
    If repairing permissions results in error messages, some of these messages can be ignored and should be no cause for concern.
  5. kirkbross, Jul 13, 2012
    Last edited: Jul 13, 2012

    kirkbross thread starter macrumors 6502a


    Mar 6, 2007
    Los Angeles
    @GGJstudios Thanks. It's odd... I'm running Lion and have the old, jam-packed, messy, Leopard drive still in the MP so I (and the other 2 users) can access old stuff from that drive while in Lion. All three Lion users are Admins btw, and all three user accounts are on a separate drive from Lion so as not to bloat the SSD with music and pictures.

    So... for one of the new user accounts in Lion I tried creating an alias of his old Leopard Desktop folder so I could place it on his Lion desktop for quick access (rather than copy 200GB of data from his old desktop to his new desktop... and don't get me started on messy, hoarder-users).

    The problem?

    While logged in as him, I am able browse and access the contents of his old Leopard desktop folder with no problem, but when I create an alias of that old desktop folder and try to access it through the alias, it says I don't have permission. Whu-huh?

    So... I tried selecting the old desktop folder > Get Info > and select his user name (which already says Read & Write) and then 'Apply to enclosed items' -- but after the changes are applied, I still can't access it from the alias.

    I know, worst-case he has to navigate to his old desktop manually, but I don't understand why the alias doesn't work.


    240 - SSD w/ Lion
    2TB - DATA
    2TB - DATA

Share This Page