Sharing Permissions - Stumped

Discussion in 'macOS' started by BJD, Jun 12, 2010.

  1. BJD macrumors newbie

    Joined:
    Jun 12, 2010
    #1
    A few days ago I purchased a Mac Book Pro and want to set up sharing so I can sync files and folders on the Mac Book with my Mac Pro. Initially, when I set up the new Mac Book Pro I used the 'Migration Assistant' to clone my Mac Pro. When my first attempt at file sharing didn't work properly, Apple tech support suggested I rename the user on the Mac Book so that it would differ from the user on the Mac Pro. So here's what I've got:

    1. Mac Pro – username Joseph (last name)
    2. Mac Book Pro – username Joe (last name)

    Basically I’ve set up each computer to share the entire ‘home’ folder and all its contents. I can view all of the shared folders/files from each computer, but even though the read-write permissions are set in the ‘accounts’ section, I cannot get the read-write permissions to function. Any attempts to copy or move a file or folder from one computer to another results in a popup "Type your password to allow Finder to make changes". Entering my password results in an error popup reading "The Finder can't complete the operation because some data in (filename) can't be read or written".
    In spite of the error, the file or folder copy process appears successful until I try to open the file and realize it's a 0KB file that can't be opened or read.

    I've gone through the following steps over the past 6 hours trying to get this resolved but no luck:
    1. Added both users on both computers in the sharing section of the 'More Info' screen
    2. Set the user permissions to 'read-write'.
    3. Initiated the 'Apply to enclosed items' function from within the gear menu.
    4. Tried connecting using both user accounts under the 'Connect As' feature in Finder under the 'Shared' section.
    5. Tried the Applications > Utilities > Disk Utility > "repair permissions." function.
    6. Deleted and recreated the keychain login info.
    7. Tried several commands with senior Apple tech support such as the sudo chown -R [username] commands.
    8. Booted to an install disk, ran Password Reset from Utilities, Reset Permissions.

    Eventually, Apply tech support cried 'Uncle' and have forwarded the info up the ladder with instructions that they'll get back to me within a week or so. :confused:

    Any suggestions would be greatly appreciated. I'd like to get this all behind me. I'm new to the Mac world and don't have much technical savvy when things get to this level.

    Thanks!
    BJD
     
  2. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #2
    I had the same problem, and Apple Care couldn't help. I believe this issue is a bug in SL somewhere. I resolved the file sharing/backup issue by using an external HD and using SilverKeeper (free software from LaCie, available on their HP, http://www.lacie.com/silverkeeper/) to synchronize my home folder. Silverkeeper must be set up correctly (make sure the "Copy set to folder" option is enabled in "Options"), but once it is, you simply plug in the HD, start up Silverkeeper and hit one button. Only files that have changed are copied. There is a backup option and a synchronize option so you are covered no matter what you want to do. Be careful the first time you use it- it is powerful software but one user mistake and you can lose data! Use the synchronize option if you want to make sure you don't lose data. You can set up backup sets going either way, Computer 1 to HD, HD to Computer 2 or Computer 2 to HD, HD to Computer 1.
    It would be much easier to simply use file sharing over AFP, but until Apple gets this straight, it's a no-go. :eek::apple::eek:
     
  3. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #3
    Questions:

    1. Did you add your home folder to the "Shared Folders" list of File Sharing?

    2. When you try to connect to the Mac Pro, what are you putting in as the server address? Is it prompting you to authenticate? If so, what user are you trying to authenticate with?

    Now some info. If you did number 1, you screwed up. You don't need to do that as by default if file sharing is turned on, the user will be able to mount their home folder.

    So, if my account name is joseph, and I connect to my Mac Pro as joseph I will be able to mount my home folder.

    I have some other ideas about the problem, but your details are pretty murky.

    My guess is that by doing what you did, you screwed up your home folder permissions. But without seeing it, I can't be sure.

    That said, this is working in 10.6.3 right now. There are no problems that I am aware of. However, you took far too many steps to do something incredibly routine. It may also be Apple's fault as they don't make it clear that your home folder is shared by default when you turn on file sharing.
     
  4. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #4
    I have 2 Macs, one is an old G5 tower, running Leopard, the other a MBP, with 10.6.3. I can mount the user home folder or the whole HD or just the Public folder via the "Go to Server" AFP protocol. But the "file permissions issue does exist. Using Silverkeeper results in an error message and an "offer" to use a sparse image instead of a regular backup copy. Using finder will produce a file permissions error when trying to overwrite an older file.
    The issue is complicated by same user names and different IDs, the 501 user, etc. So, while I am glad it is working for you, I sure wish I could get it working! Apple Care went round and round with me on this, no conclusion, no admission of blame either. Several long posts by forum members MUCH more informed than I am led to the conclusion that it is a bug in SL, existing from the initial release and not improved by the updates so far.
     

Share This Page