Sharing the internet connection of the Mac..help needed.

Discussion in 'macOS' started by XheartcoreboyX, Sep 17, 2009.

  1. XheartcoreboyX macrumors 6502a

    XheartcoreboyX

    Joined:
    Jul 3, 2007
    #1
    I need to share the internet connection of my Macbook to my Samsung TV which has internet functions, through an ethernet cable, the Macbook is connected to the internet through a Wireless connection from a router.

    What setting do I need to go through? I tried some steps that didn't work, so I just though I would ask for the right way.

    Data needed in TV:

    IP Address : xxxx
    Subnet Mask: xxxx
    Gateway: xxxx
    DNS Server: xxxx

    BTW I can access the Linksys router setup page if needed.

    ~Thanks for any help.
     
  2. NeverhadaPC macrumors 6502

    NeverhadaPC

    Joined:
    Oct 3, 2008
    #2
    you need to hook up your macbook to an ethernet connection and broadcast internet via your Airport --- in Sharing---> internet sharing.

    or connect your tv via ethernet and keep your wireless connection on your mac.

    You cannot receive and broadcast wirelessly with one Airport card --- please prove me wrong though. :D
     
  3. XheartcoreboyX thread starter macrumors 6502a

    XheartcoreboyX

    Joined:
    Jul 3, 2007
    #3
    That's the case here. :p
     
  4. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #4
    More specifically, in the Sharing preference pane in System Preferences:

    - Select Internet Sharing on the left of the pane. (you cannot check the box yet)
    - Select "Airport" from the drop-down menu on the right if it is not selected.
    - Check the "Ethernet" checkbox in the area below the drop-down menu.
    - Check the "Internet Sharing" box on the left to turn it on.

    Your Samsung TV should be getting an internet connection at this point.

    Unless you're saying that doing that didn't work? :D
     
  5. XheartcoreboyX thread starter macrumors 6502a

    XheartcoreboyX

    Joined:
    Jul 3, 2007
    #5
    That was done already with no help, i think i have to enter those details in the first post manually, I just need to make sure where do i exactly get these data and also in Network>Ethernet, what IP and subnet mask do I enter when configured manually?!
     
  6. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #6
    Ok, do the first set of instructions I posted and leave them configured that way.

    Then do the following:

    On OS X:
    - Go into the Network Pane and Select Ethernet
    - In the Configure IPv4 drop down, select "manually".
    - Put a non-routable IP address. If your router uses 192.168.x.x, then you would put 10.x.x.x. (As an example, I will use 10.0.0.1. The link explains more.)
    - For the subnet mask, my router uses 255.255.255.0 so I put 255.255.0.0.

    On the Samsung:
    - IP address - increase the address you used on your Mac by one. In my example, 10.0.0.2.
    - Subnet mask - same as the one entered on the Mac.
    - Default gateway - put the IP of the Mac here (10.0.0.1 in my example)
    - DNS Server: I use OpenDNS. Their addresses are 208.67.220.220 and 208.67.222.222. Or you can put your ISP's DNS server here.

    Please say it works ... *prays*
     
  7. XheartcoreboyX thread starter macrumors 6502a

    XheartcoreboyX

    Joined:
    Jul 3, 2007
    #7
    That actually does kinda work, the network test went through, which is pretty darn good, but no internet connection, yet. :(
     
  8. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #8
    Maybe you forgot to turn Internet Sharing on in the first step? For some reason it has to be on to work. (I tested it before.)

    You can also turn it on afterwards, so don't feel like you have to start over from scratch.

    Alternatively, if you can find some way for the Samsung to do DHCP, you wouldn't have to do all that configuration that I wrote about in my last post :D
     

Share This Page