Sharing Time Machine drive over AFP, can't change permissions

Discussion in 'macOS' started by MrCrowbar, Feb 4, 2008.

  1. MrCrowbar macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #1
    I just got a Mac mini which I intend to use as home server. My Time Machine Drive (a dedicated USB drive) was backing up my Macbook via USB, now it's attached to the Mac mini. Both Macs are on the same network.

    Now I wanted to get wireless backup working so I I enabled File Sharing (over AFP) for the TM (Time Machine) drive on the Mac Mini and I could select it just fine as the Time Machine Volume from my Macbook's Time Machine preferences. Sadly, Time Machine makes a new folder tree instead of continuing the old ones, but I can live with that. What is really annoying me is that the TM drive is shared so everyone on the network can browse it, yes everyone including "guests" can drill into my backups and see all my stuff. Apparently, I can only set user specific permissions on Folders, but not on Volumes. Is there a way to change that?

    I want my Macbook's backupdb folder to be only accessible by my account on my Macbook and the admin account on the Mac mini. Is there any way to do that? I just want a file server that's not open to anyone.

    [​IMG]
    When I try to choose the permissions for "Everyone", "no access" is greyed out. :-( please help
     
  2. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #2
    Have you tried partitioning the backup drive and setting different permissions on each?

    Is locking down your network an option?
     
  3. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #3
    Partitioning is an idea. I'm tryong that and will report here.

    My network is a locked down as possible, WPA with a 128 character random key and Access Control (only certain MAC adresses allowed). This is still hackable but safe enough. The thing is, when I have guests in the house and open the network for them (via ethernet or WLAN), I don't want them to see my backups.
     
  4. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #4
    nope, partitioning didn't help:

    [​IMG]

    I made the TM Macbook partition tu use as TM drive for my Macbook. Still, everyone has read only access. It seems I can only have the "no access" restriction on folders, but Time Machine wants a Volume, not a folder.

    While typing this, I got the idea of having a folder with a volume (disk image?) inside it.
     
  5. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #5
    Nope, can't use the disk image inside the shared folder with Time Machine. I can't believe Apple did not think about public backups...
     
  6. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #6
    Success (I think)!

    Disable all file sharing.

    On the server, right-click your backup drive, "get info".

    [​IMG]

    Uncheck "Ignore ownership on this volume", then set "everyone"'s permission to "No Access" as seen in the screenshot. Now check the "Shared Folder" Box.

    Open the Servers Sharing Preferences and enable AFP.

    On the Client, connect to the server (remote login on server account). Then, open Time Machine Preferences and you should get the remote Drive as available volume.
     
  7. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #7
    Well, it works but it's so damn slow it drives me nutes. Even when on a not busy 100 Mb/s network, I barely get 1 Mb/s when transferring anything between my two Macs. Is there a reason why it's so damn slow?
     
  8. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #8
    Hmmm...

    Which Macs and what kind of router?
     
  9. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #9
    Router: Netgear WGR614v5 (100 Mbit Ethernet, 802.11g)
    Mac (server): current Mac Mini 1.83 GHz Core 2 Duo (Gigabit Ethernet, 802.11g)
    Mac (client): Gen 1 Macbook 2.0 GHz Core Duo (100 Mbit Ethernet, 802.11g)

    Transfer speed is the same when having both Macs connected directly in the router's ethernet ports and when on wireless (full bars). I can still have plenty of bandwidth for internet stuff using any of the Macs. I can't really believe it's the AFP or SMB protocol that are so slow, again, I get similar speeds with either protocol.

    I remember having fast transfers from my Mac to a roommate's PC so that's kind of ruling out a routing bottleneck, right? I'll try to hook them up to another network anyway just to be sure.

    Any advice? Thanks for helping.
     
  10. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #10
    Testing

    I'm going to test my speeds when I get home. I have:

    Airport Extreme Router (last of the round ones, so about a year old)

    G4 Tower connected via ethernet

    12"Pbook via 802.11g, G5 via 802.11g and a Macbook with an N card (but obviously connected via 802.11G)

    I remember it taking the better part of an hour to transfer 5 gigs of video from the G4 to the G5 once.
     
  11. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #11
    Thanks.
     
  12. tdhurst macrumors 68040

    tdhurst

    Joined:
    Dec 27, 2003
    Location:
    Portland, OR
    #12
    yeah...

    1.5 MB per second from 100Mbit connected G4, through Airport Extreme, to Powerbook running 802.11g. 354 MB file in about 4 minutes.

    Same file from Powerbook to G5 (802.11g) is about half that fast.

    My network is set up for G speeds only.
     
  13. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #13
    Damn, same here. Why is it so slow? My internet is even faster than that, and it goes throught the same router.
     
  14. MrCrowbar thread starter macrumors 68000

    MrCrowbar

    Joined:
    Jan 12, 2006
    #14
    Hmmm apparently those speeds are normal :-(

    Source: http://www.macintouch.com/reviews/airportn/
     

Share This Page