Sharing Time Machine Over Network

Discussion in 'Mac Basics and Help' started by Siron, May 29, 2008.

  1. Siron macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #1
    Sorry if this has been addressed before (I did a search here but no luck).
    I have a MP with a connected USB drive for TM. I want to back up my MBA over the WIFI network to this TM disk. I understand that you have to have the MP up and running but I'm unclear about setting up sharing as I don't want anyone other than the MBA to be able to connect to it.
    Can someone please explain how to set up each machine so I can "see" the TM disk from my MBA via WIFI? My WIFI is encrypted with WPA2
    Thanks in advance.
    Alan
     
  2. metalray@mac.co macrumors member

    metalray@mac.co

    Joined:
    Oct 10, 2006
    Location:
    San Diego, California
  3. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #3
    Easy...

    On the MP, open Sharing Prefs (in System Prefs) and check the box for File Sharing to start it. In the Users pane, select the users you don't want to have access and use the "-" button to remove them from the access list.

    When you are ready to do a TM backup of your MBA, go to the "Shared" section in the sidebar of the Finder Window and click on the MP. Then click on the TM drive (on the MP) to mount it. Now you can do a TM backup of the MBA.

    Let me clarify (I looked at this after I posted the reply and thought this may confuse you) this...

    This is all done on the MBA.

    Thanks Merl1n
    That was a quick response. Sounds very easy. Do I have to specify the name of my MBA as an "Allowed User" (I have a name for both machines - the MP is JohnDoe's-Desktop and the MBA is JohnDoe's-NoteBook).
    Alan

    No, it's the user account name you specify in the Sharing Prefs. If you have the same user name on both machines then you are good to go. If you don't that is still not a problem.

    On your MBA, when you first try accessing your other Mac, you'll click the "Connect As..." button. A popup window will be drawn asking for the user name and password. You type in the user account name on the Mac (not the MBA) you are connecting to and enter the user name password. If you check the box at the bottom of the window (Remember...), it will add it to your keychain on the MBA. After that first login, you will not be asked again.
     
  4. Siron thread starter macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #4
    Didn't Work

    Well
    I opened Sharing in System Preferences on the MP, turned on File Sharing and added Time Machine as a Shared Folder.
    I went to the MBA opened Finder and my MP showed up under "Shared" but it tried to connect for about two minutes and the said "Connection Failed"
    What am I doing wrong here? :confused:
    Alan
     
  5. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #5
    "...added Time Machine as a Shared Folder."

    Undo that.

    Just have File Sharing turned on on the MP. Check the drive you are using for TM by doing a Get Info and make sure "Ignore Ownership...." is not checked.

    On the MBA, click on the MP system under shared and then click on the TM drive. Does it mount on your MBA? It must be mounted on the MBA first, before TM will recognize it as available.

    Report Back.
     
  6. Siron thread starter macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #6
    Merl1n
    I removed the TM disk under "Shared Folders". I did a Command I on the TM disk to bring up the Info window, but I cannot see anything where I can uncheck "Ignore Ownership".
    I still cannot connect.
    Funny thing is, I can connect to my MBA from the MP. :confused:
    And - it says "Connected as .myname@mac.com" (my .mac account). :confused::confused::confused:
    BTW thanks for all your help :)
    Alan
     
  7. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #7
    Toggle File Sharing off and on.

    On the MBA in a Finder Window make it column view.
    On the sidebar in this window you should see your MB under Sharing.
    Click on that.
    Now in the Window, Click "Connect As..."
    If it is filled in with your .mac name, clear it, and put in the admin user name from your MP and Password and check the box at the bottom so it is added to your keychain on your MBA.

    In this same finder window, you should see all of the disks from the MP. Click on the one for TM and you should see an up triangle appear showing it is now mounted.
     
  8. Siron thread starter macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #8
    Merl1n
    I appreciate your patience. I have tried that but it doesn't work. When I click on the MP in Finder on the MBA I see the "connect as" button but it's still trying to connect so that button is inoperable until I get the "connection failed" message. When I click on the "Connect As" button it still tries to connect with no success. Could it be my Netgear router only allowing outgoing traffic over a certain port that File Sharing uses? I say this because I can connect to my MBA from my MP with no problems.
    Just a thought.
    Alan
     
  9. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #9

    Try this (I don't know if it will work)...

    1. On the MBA, turn off your .mac account in System Preferences -> .mac
    2. Turn off File Sharing on both Macs
    3. Change the name on both Macs (Sharing Prefs) Computer name and Click the Edit button. Change that name so it shows the same name (it should look like name.local). When choosing a name, keep it simple (ie, one of mine is called Hellraiser and another is called WishMaster) and DO NOT USE ANY SPECIAL CHARACTERS IN THE NAMES, such as apostrophes, dashes, etc.
    4. Reboot both computers.
    5. On the MP, turn on file sharing.

    Now test again.

    If it works, turn on .mac again on the MBA and test again.
     
  10. Siron thread starter macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #10
    Merl1n
    I changed the MBA name to MACBOOKAIR. In the Sharing screen it says in the Computer Name window ALAN's Desktop but below that it now says: "Computers on your local network can access your computer at: MACBOOKAIR.local"

    I changed the MP to MACPRO and it shows a similar message Computers on your local network can access your computer at: MACPRO.local

    I did as you said and then rebooted but on the MBA in Finder the MP shows up as Alan's Desktop (which is the name that appears in the Computer Name window of Sharing) and not the new name I entered. It still does not connect.
    I now cannot connect from my MP to the MBA (which I could before) :confused:
    Alan
     
  11. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #11
    Well that's wrong. In Sharing Prefs you should see:

    MP: Computer Name = MACPRO and beneath MACPRO.local
    MBA: Computer Name = MACBOOKAIR and beneath MACBOOKAIR.local

    Change them the way they should be and then...

    If you have OnyX, (download it if not), run it and clear ALL of your caches (System, Users, Fonts, etc.) on both computers. Then reboot both computers

    Check the Sharing Prefs again to make sure the computer names read correctly.
     
  12. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #12
    I just sent you a PM. Please respond tonight.
     
  13. Siron thread starter macrumors 6502

    Siron

    Joined:
    Feb 4, 2008
    Location:
    North Carolina
    #13
    Found the Problem

    I had Firewall set to Specific Applications. Changed it to Allow All Incoming and I can now connect to the MP.
    Alan:D
     

Share This Page