sharing wifi over ethernet

Discussion in 'OS X Mavericks (10.9)' started by legoxx, Jan 24, 2014.

  1. legoxx macrumors newbie

    Joined:
    Jan 24, 2014
    #1
    Hello,

    My ISP is providing internet over WIFI
    I would like to share this internet to the rest of my network over ethernet


    I have mevericks on my mac mini,
    there are two interfaces
    - wifi with DHCP on (resolved address is 192.168.0.15)
    - ethernet manually configured for my local network (10.0.0.2)

    how to share the internet from wifi to ethernet?

    Turning internat sharing will not solve it, i belive it's broken:

    - with internet sharing off you can ping 192.168.0.15 and 10.0.0.2 from mac mini
    - with internet sharing on you can ping 192.168.0.15 but not 10.0.0.2

    how should be computers in local network configured so they will use mac mini to go to internet?

    thank you for your help
     
  2. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #2
    I can't test this right now (at least not without turning my network inside out), but:

    1) I think Internet Sharing should work.
    2) OS X may ignore your manual configuration of the Ethernet, and pick its own network.
    3) Computers on your network should use DHCP or will need to be configured to talk to whatever network OS X uses.

    A.
     
  3. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #3
    I second this.

    2) OS X may ignore your manual configuration of the Ethernet, and pick its own network.

    My MBP does ignore any manual configuration of the Ethernet :
    My wifi network is in the 192.168.1.x range, my router being 192.168.1.1.
    When I turn Internet sharing ON (wifi to Ethernet), and do an IP scan of the network, the MBP shows up as a "router", IP : 192.168.2.1

    3) Computers on your network should use DHCP or will need to be configured to talk to whatever network OS X uses.
     
  4. legoxx thread starter macrumors newbie

    Joined:
    Jan 24, 2014
    #4
    but how to start DHCP server on OS X? Is it OS X server feature only? or alternatively how can i configure computers to use DHCP from the WIFI as it's on other network?

    thank you
     
  5. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #5
    You don't need to : as soon as you turn Internet sharing, your Mac acts as a router with DHCP server.
     
  6. Bruno09, Jan 24, 2014
    Last edited: Jan 24, 2014

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    You don't need to : as soon as you turn Internet sharing on, your Mac acts as a router with DHCP server.

    No, it's not an OS X server feature only.
     
  7. legoxx thread starter macrumors newbie

    Joined:
    Jan 24, 2014
    #7
    the thing is that there is an airport express in internal network that I want to use for my other wifi devices. When I configured it as "use DHCP" LED just went orange... i suppose it was not able to resolve an IP address
     
  8. Bruno09, Jan 24, 2014
    Last edited: Jan 24, 2014

    Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #8
    The led is also orange when you have a "double NAT" setup, which is the case here.

    This does not mean that the AE is not working fine, it just means double NAT (2 routers in the same network).

    Open Airport utility to see if the AE got an IP address from DHCP and if it says : "double NAT".

    (I assume your have the AE connected to the wired network that comes from the Mac, rIght ?).
     
  9. legoxx thread starter macrumors newbie

    Joined:
    Jan 24, 2014
    #9
    yes AE is connected to wired port of Mac Mini,

    well after setting AE to DHCP... i can't no longer access it with airport utility:( neither from mac mini over ethernet, neither from macbook air over the wifi
    i'll try to figure out how to reset it.
     
  10. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #10
    I think I would verify that Internet Sharing is working by using a wired host before I tackled the Airport Express, since the latter is a bit more of black box to debug.

    A.
     
  11. legoxx thread starter macrumors newbie

    Joined:
    Jan 24, 2014
    #11
    it seems that i got it working at the end
    I have reset AE, It went to DHCP & NAT mode
    what is creating this double NAT warning,

    basically Mini is doing DHCP and NAT with internet
    sharing, maybe i can put AE to bridge only mode

    but i'm a bit afraid to do it because everything is
    working now;-)

    thank you for your help
     
  12. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #12
    The AE in bridge mode should work too.

    You need to have it in bridge mode if you want your wifi devices to have access to the other wired devices.

    At the moment, they can't.

    You said that you Mac's IP address is 192.168.0.x over wifi.

    For information, what is the IP address the AE got from the Mac ??
    Is it 192.168.1.x, or something else ?

    Thank you.
     
  13. legoxx thread starter macrumors newbie

    Joined:
    Jan 24, 2014
    #13
    final configuration after switching AE to bridge only

    Mini
    - wifi (external): 192.168.5.119
    - ethernet (internal): 192.168.2.1

    AE
    - lan: 192.168.2.3
    - wifi: 192.168.2.3 (same as it's bridge mode)

    macbook air, NAS, ipad, iphone, onkyo: all internal addresses 192.168.2.x (assigned by Mini DHCP)

    now the question for 100 points;-) how to persuade Mini to send all outside traffic through VPN (i'm using privateinternetaccess.com)

    when i configure VPN in Mini settings only traffic originating at Mini is going through VPN, but all routed traffic from inside network is going on open channel

    thanks;-)
     
  14. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #14
    In System Preferences/Network/VPN/Advanced, you need to check the box that says "Send all traffic over VPN connection". I'm guessing that you have done this already, and it is not doing what you want. One simple thing that you can try is this: In System Preferences/Network in the lower left is a gear icon. One of the selections is "Set Service Order". Choose this and in the box that pops up drag the VPN connection to the top of the list. You will want to restart the VPN connection in order to test this.

    If that does not work, it gets complicated.

    A.
     

Share This Page