Sharing with Windows Computers and Leopard

jcjcjc87

macrumors newbie
Original poster
May 18, 2006
20
0
Hey guys,

I recently updated my Macbook to leopard and for the most part everything is working Ok. However I have to share files with a network with windows computers. I never had a problem with Tiger, My Home folder would be shared and as long as you typed in the password access to it was fine. What I liked was my Home folder was the only folder you could access.

Now with Leopard, my home folder is shared, however so is my whole HDD, even if i had a usb drive plugged in at the time, that is shared too. Can I change this to so only my home folder is shared, like it was with Tiger.

I have tried playing with the firewall and other sharing setting but cannot work it out. Hope someone can help!!

Cheers,

Jason
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
Hey guys,

I recently updated my Macbook to leopard and for the most part everything is working Ok. However I have to share files with a network with windows computers. I never had a problem with Tiger, My Home folder would be shared and as long as you typed in the password access to it was fine. What I liked was my Home folder was the only folder you could access.

Now with Leopard, my home folder is shared, however so is my whole HDD, even if i had a usb drive plugged in at the time, that is shared too. Can I change this to so only my home folder is shared, like it was with Tiger.

I have tried playing with the firewall and other sharing setting but cannot work it out. Hope someone can help!!

Cheers,

Jason
This is normal - if you wish to change the defaults go into System Preferences, click Sharing, then look in there - I know there are options for specifying exactly what you want shared. I'd tell you where they were but I'm not at my Mac right now.
 

jcjcjc87

macrumors newbie
Original poster
May 18, 2006
20
0
I have gone into sharing in system preferences and the only folders I have shared are my home folder and my Public Folder, but it still shares my whole HDD.
 

bob007

macrumors newbie
Nov 18, 2008
4
0
This is normal - if you wish to change the defaults go into System Preferences, click Sharing, then look in there - I know there are options for specifying exactly what you want shared. I'd tell you where they were but I'm not at my Mac right now.
hi
I have the same problem.
Please tell us what is the solution for this...

if i share a folder, my leopard shares the whole hdd with it.

So if you had already done it. please share with me :)


thank you very much:cool:
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH

bob007

macrumors newbie
Nov 18, 2008
4
0
Open System Preferences, then Sharing. Turn File Sharing on, if it isn't on. Then... see this Apple Support article for the details:
http://docs.info.apple.com/article.html?path=Mac/10.5/en/17131.html
thank you for your quick reply.

Unfortunatelly, this does not solve the problem in 100%.
at my macbook im the only user bob (admin priv.) and guest (login off share off)
when i share with bob, and do the support step by step, when i connect from the windows pc (simply with totalcmd and i write \\192.168.2.32\) then the windows ask me a password. I give the bob user and password then it connects successfully, but (i think because i am an admin user) i see all my hard disks and my home(user) folder in the macbook and my shared folder.

what i would like to do, if it is possible (in tiger it was possible, i have friends who uses tiger, and it works like winxp... ) that i share a probe folder, then anybody who is at my network LAN, could see me, and ONLY my shared folder. no user/password requies and not shown the whole hdd :)

is this possible? i use leopard 10.5.5. and i think this is a small bug :(

waiting for your answere, and thanks again.
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
thank you for your quick reply.

Unfortunatelly, this does not solve the problem in 100%.
at my macbook im the only user bob (admin priv.) and guest (login off share off)
when i share with bob, and do the support step by step, when i connect from the windows pc (simply with totalcmd and i write \\192.168.2.32\) then the windows ask me a password. I give the bob user and password then it connects successfully, but (i think because i am an admin user) i see all my hard disks and my home(user) folder in the macbook and my shared folder.

what i would like to do, if it is possible (in tiger it was possible, i have friends who uses tiger, and it works like winxp... ) that i share a probe folder, then anybody who is at my network LAN, could see me, and ONLY my shared folder. no user/password requies and not shown the whole hdd :)

is this possible? i use leopard 10.5.5. and i think this is a small bug :(

waiting for your answere, and thanks again.
You need to enable file sharing for the Guest account first. Once that's done (you can do this in the Accounts preference pane), go back to the Sharing pane. Click the plus. Go find the folder you wish to share. Add the guest account to the list of people allowed to use this shared folder. Then, proceed as per the article.
 

bob007

macrumors newbie
Nov 18, 2008
4
0
You need to enable file sharing for the Guest account first. Once that's done (you can do this in the Accounts preference pane), go back to the Sharing pane. Click the plus. Go find the folder you wish to share. Add the guest account to the list of people allowed to use this shared folder. Then, proceed as per the article.
thanks, its works now.
i activate guest account only share
i active file share at syspref. smb option on, no user selected at the options.
i copy the folder to the users public folder, than i share my users public folder. for everyone read and write, windows user can read/write, if everyone readonly... etc.

this was the best way, not to show the whole hdd, and windows users do not have to enter password.


thank you for your replies, and time.
 

tonyl

macrumors 6502
Jan 18, 2006
284
0
You need to enable file sharing for the Guest account first. Once that's done (you can do this in the Accounts preference pane), go back to the Sharing pane. Click the plus. Go find the folder you wish to share. Add the guest account to the list of people allowed to use this shared folder. Then, proceed as per the article.
do you know why I can't connect to my home folder from a Linux box but fine to other hard drives?
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
do you know why I can't connect to my home folder from a Linux box but fine to other hard drives?
That is odd. Linux doesn't understand AFS but can connect to Mac shares with SMB or NFS (SMB's easy to set up; NFS is considerably more difficult as there's no GUI).
 

boppin

macrumors regular
Jun 14, 2008
173
17
Germany
You need to enable file sharing for the Guest account first. Once that's done (you can do this in the Accounts preference pane), go back to the Sharing pane. Click the plus. Go find the folder you wish to share. Add the guest account to the list of people allowed to use this shared folder. Then, proceed as per the article.
Hello,

when I click on the + I don't see a user called "guest". How can I add it?
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.