Shark and XCode 3.2.6

Discussion in 'Mac Programming' started by friedmud, Mar 24, 2011.

  1. friedmud macrumors 65816

    Joined:
    Jul 11, 2008
    #1
    Anyone out there successfully using Shark with XCode 3.2.6? Even creating something simple like:

    Code:
    int main()
    {
      int i=0;
      
      for(;;)
        i++;
    }
    and compiling it with "g++ -g something.C"... running it and trying to sample it with Shark is not working.... It just shows up with "Unknown Library" and unreadable symbols.

    Any ideas?

    Alternatively... anyone have a link for downloading XCode 3.2.5? I can't find a link for it anymore (damn you Apple!).
     
  2. kainjow Moderator emeritus

    kainjow

    Joined:
    Jun 15, 2000
    #2
    Works fine for me. Maybe try reinstalling Xcode again?
     
  3. friedmud thread starter macrumors 65816

    Joined:
    Jul 11, 2008
    #3
    Thanks for the reply.

    As it turns out... that's what I did to resolve it. I had originally installed 3.2.6 from software update, so I tried downloading the dmg and installed it over my existing installation... And it worked!

    No idea what was hosed up... but hopefully this can help someone else if they run into it.

    Derek
     
  4. isgoed, Aug 22, 2011
    Last edited: Aug 23, 2011

    isgoed macrumors 6502

    Joined:
    Jun 5, 2003
    #4
    I have the exact same problem. It drives me nuts. I Also have version 3.2.6. I haven't tried reinstalling, but let's see if it helps.
    ---->
    OK, it worked, but I had to be very thoroughly:

    First try:
    • I updated over my existing install 3.2.6 and restarted, but that did not work
    Then I reinstalled:
    • uninstalled xcode with:
    • sudo /Developer/Library/uninstall-devtools --mode=all
    • I restarted
    • Installed XCode 3.2.6 from the downloaded dmg, but I did not install iOS development tools (by disagreeing to the license agreement).
    • Shark still not worked
    Third time:
    • uninstalled again.
    • restarted
    • installed, but now with agreeing to iOS license agreement. Select 10.4 development kit. Deselect unix development tools.
    • restarted
    • Now shark works.
    But my Developer directory is now 10.45 GB in size. And I have something like 7GB less free disk space. I am gonna delete some off the stuff i won't need.
     

Share This Page