Resolved Sheepshaver hangs on desktop

Discussion in 'PowerPC Macs' started by jrsx, Mar 23, 2014.

  1. jrsx, Mar 23, 2014
    Last edited: Mar 26, 2014

    jrsx macrumors 65816

    jrsx

    Joined:
    Nov 2, 2013
    Location:
    Tacoma, Washington
    #1
    I'm trying to get SheepShaver to run OS 9 in OS X Leopard, and I got everything working, but when OS 9 boots up, it hangs at the desktop for a minute before it loads anything. I've tried everything. I deleted all the invisible preference files, reinstalled OS 9, deleted the PRAM values, tried different RAM and window sizes, etc. Nothing works. It has worked fine before, except for the occasional freezes because of CPU hunger. My CPU works at 100% when this happens. After about a minute, it does load everything, but what do I have to do to stop these hangs? Also, when using the built-in preferences editor, it saves the preferences, but SheepShaver crashes then, and has to be restarted. Is this normal? I am using the October 2009 build, since the newest February 2014 built crashes and won't save changes, although it supposedly works with Tiger and Leopard. Thanks in advance,
    jrsx
     

    Attached Files:

  2. jrsx thread starter macrumors 65816

    jrsx

    Joined:
    Nov 2, 2013
    Location:
    Tacoma, Washington
    #2
    Now for whatever reason, Sheepshaver won't even start, even with all the preferences configured properly. Strange. I just get the "?" sign, but it won't boot from anything.
     
  3. WMD macrumors regular

    Joined:
    Jun 12, 2013
    Location:
    Florida, USA
    #3
    Try digging up one of the 2012 or 2013 builds, see if it helps. They should still be around on their forum.
     
  4. jrsx thread starter macrumors 65816

    jrsx

    Joined:
    Nov 2, 2013
    Location:
    Tacoma, Washington
    #4
    I looked around but couldn't find any... I thought of this because I used SS last year and it worked fine, no flaws. But with the new build from February, it doesn't work at all, so I tried a 2009 build that they recommend for PPC. Those are the only two versions I found on the site.
     
  5. WMD macrumors regular

    Joined:
    Jun 12, 2013
    Location:
    Florida, USA
    #5
    Ok, no problem... I found the 2012-07-15 build on my computer, which is Universal. I'll PM it to you shortly.
     
  6. jrsx thread starter macrumors 65816

    jrsx

    Joined:
    Nov 2, 2013
    Location:
    Tacoma, Washington
    #6
    THANK YOU! It's working! At least for the time being...
    The built-in preferences kept freezing at full CPU power when I tried to save them, so I just used the stand-alone prefs editor, which worked. It crashed a couple times on bootup, but now it's working! Thanks!
     
  7. WMD macrumors regular

    Joined:
    Jun 12, 2013
    Location:
    Florida, USA
    #7
    Wow...I'm kind of surprised that's all it took. :D

    If you have problems with CPU usage, and are running it on a PPC Mac, trying lowering the screen refresh to 15Hz. Apparently, that's a known problem on PPC. (Probably still faster than running on Intel, since you don't have to emulate anything; I feel like it turns my Core 2 Duo into a 604e.)
     

Share This Page