ShhMBP has not been started because it does not have the proper security...

Discussion in 'MacBook Pro' started by markfrommarton, Apr 3, 2011.

  1. markfrommarton macrumors newbie

    Joined:
    Apr 3, 2011
    Location:
    New Zealand
    #1
    I've just made a fresh 10.6.7 install on my MacBook Pro 2 GHz Intel Core Duo. I loaded it from a 10.6 Install Disk and then did the 10.6.7 combo update.

    Unfortunately ShhMBP no longer works, so I now have to put up with the terrible processor whine that ShhMBP was designed (very cleverly) to stop.

    After startup and login I know receive the message:

    Insecure Startup Item disabled.
    "/Library/StartupItems/ShhMBP" has not been started because it does not have the proper security settings.

    I tried changing the attributes using BatChmod, to system -r -w -x wheel -r -w -x, and then did the same in Terminal using "sudo chown -R root:wheel /Library/StartupItems/ShhMBP/".

    I then tried removing a possible quarantine attribute using "sudo xattr -r -d com.apple.quarantine /Library/StartupItems/ShhMBP". I doubt that was the issue anyway.

    I'm a bit puzzled and more than a little ticked off about this. Any help from anyone would be hugely appreciated.

    Thanks in advance,

    Mark.

    P.S: I've followed the advice through the thread at http://forums.macrumors.com/showthread.php?t=779410 but to no avail. This appears to me to be a new problem with 10.6.7, yeah?
     
  2. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #2
    I don't understand, wats wrong with the built in SSH client?
     
  3. DaffyDuck macrumors 6502

    Joined:
    Jun 18, 2007
    #3
    I would take it to the Genius bar and see what they say. They may have pity on your situation and do something nice like replace the mainboard or something like that.

     
  4. calderone, Apr 3, 2011
    Last edited: Apr 3, 2011

    calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #4
    Proper permissions on startup items are:

    0755 for directories, executables
    0644 for non-exec files

    Owned by root:wheel.

    A quick note, StartupItems have been deprecated since 10.5. No modern software should be using it, but instead using launchd.
     
  5. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #5
    It's not SSH. It's to fix some noise on certain models.
     
  6. emiljan macrumors 6502

    emiljan

    Joined:
    Jan 25, 2010
    Location:
    Michigan

Share This Page