Shift 8ik, keys not working

Discussion in 'macOS' started by surprisesbrian, Aug 18, 2010.

  1. surprisesbrian macrumors newbie

    Joined:
    Aug 18, 2010
    #1
    i'm a newbie here and hope this is the right forum. it doesn't seem to be a hardware problem.

    in lower case, or without the shift key, all my keys work normally. However, when i try type 'Shift-i" nothing happens. When i type "caps-lock-i", i get "I".

    The same is true for: 8, i, k and ",". Also, my cursor isn't jumping to the last position in the line when i use [right side]Command-rightarrow. it does when i use [left side] command-right arrow.

    My six-year-old son plays a few games on the computer and may have changed some settings by accident. i cannot find whatever settings he may have changed.

    Please help, even if your help is telling me where i should post this request.

    I have typed out my keyboard keys so you can see which ones aren't working and under what circumstances:
    Have a look as i type the keys in order:

    Capslock

    1234567890

    QWERTYUIOP

    ASDFGHJKL;

    ZXCVBNM<> All okay!

    Holding the left-side shift key

    !@#$%^&*()

    QWERTYUOP

    ASDFGHJKL:

    ZXCVBNM<> No “I”

    Holding the right-side shift key

    !@#$%^&()

    QWERTYUOP

    ASDFGHJL:

    ZXCVBNM> No “*”, “I”, “K”, “<”

    Free (No shift or capslock)

    1234567890

    qwertyuiop

    asdfghjkl;

    zxcvbnm,. All okay!
     
  2. surprisesbrian thread starter macrumors newbie

    Joined:
    Aug 18, 2010
    #2
    The problem fixed itself or anyway has gone away.
     

Share This Page