shift key and a few others not working

Discussion in 'iMac' started by chopchop, Mar 27, 2011.

  1. chopchop, Mar 27, 2011
    Last edited: Apr 1, 2011

    chopchop macrumors newbie

    Joined:
    Mar 27, 2011
    #1
    Hi -

    I'm new here and I'm having some keyboard issues that I can't believe I haven't been able to fix on my own yet. Hope someone out there can help!

    I'm working with on a little older iMac - running 10.4.11 - Intel.

    My right shift key, arrow up key, and the 4, 5, and 6 keys on the number pad are all not working. Nothing has spilled.

    I've plugged in a different keyboard - same problem. Zapped pram - problem remains. Trashed prefs, restarted, repaired disk permissions, mouse keys off, checked international settings, speech setting off - everything I could find online - nothing has worked.

    Anybody have any thoughts?

    Thank you!
     
  2. farf, Mar 30, 2011
    Last edited by a moderator: Mar 30, 2011

    farf macrumors newbie

    Joined:
    Mar 30, 2011
    #2
    I have not tried to fix my problem to the extent that you have but I do have exactly the same problem. My configuration is different: I am using an Intel Xeon Quad-Core Pro with an external USB wired keyboard running OS X 10.6.7.

    My only insight is that I am running the Apple keyboard viewer and it confirms that these keys are not being seen. My right hand + key is also not working. I don't know if this is a new problem or if I just haven't noticed it before. It became evident doing my taxes last week :(

    I think I have shown that your problem is not specific to the iMac since I have the same issue on a pro platform (see my previous post). I think it may be helpful for us both if you move your post to the Mac Peripherals forum to get a larger audience. Your post lists lots of things you have tried which should help focus any discussion. I tried to email you but I couldn't find a way through this forum.
     
  3. chopchop thread starter macrumors newbie

    Joined:
    Mar 27, 2011
    #3
    Thank you for your reply farf - and thank you for trying to email me.

    I'll take your advice and move my post.
     
  4. chopchop thread starter macrumors newbie

    Joined:
    Mar 27, 2011
    #4
    farf - I can't find your previous thread.

    I also can't find how to move my post to the peripherals forum. Do I just repost it there? Anyone?
     
  5. Spikestrip macrumors member

    Spikestrip

    Joined:
    Apr 1, 2011
    Location:
    California
    #5
    I'm not sure what the problem is, but often when you can't find what appears to be a setting problem, the setting is within Universal Access in System Preferences. Kinda sounds like "Mouse Keys" might be turned on, but I think you'd have more keys not responding properly. You can open "Keyboard Viewer" from within the Keyboard Preference Pane. First click the box that says "Show Keyboard and Character Viewer in Menu Bar." Then, in that menu bar item, click on "Show Keyboard Viewer" and you can see if the computer is actually recognizing your button presses.

    Spike
     
  6. farf macrumors newbie

    Joined:
    Mar 30, 2011
    #6
    chopchop - sorry for the delay. Just read your post today and unfortunately I don't know how to move a post either. Probably quickest to simply copy/paste & repost. Good luck.

    P.S> My previous thread disappeared when a moderator combined two posts into one so you are not missing any other info from me.

    spikestrip - thanks for the response. I have the keyboard viewer running and sure enough the computer never sees the keys. Does that help?
     
  7. Ensoniq macrumors regular

    Joined:
    Jul 16, 2002
    Location:
    Bronx, NY
    #7
    Farf & ChopChop -

    A client of mine on an iMac is having the same keyboard issue.

    Right-Shift, 456+ on number pad, Up-Arrow and Right-Control aren't working.

    Did either of you ever resolve the issue?
     
  8. noddy44, Nov 13, 2012
    Last edited: Nov 13, 2012

    noddy44 macrumors newbie

    Joined:
    Nov 13, 2012
    #8
    mac keyboard (right)shift, 4, 5, 6 (number pad), and up-arrow keys all not working

    mac keyboard (right)shift, 4, 5, 6 (number pad), +, and up-arrow keys all not working... they were working earlier today!

    None of these keys shows up in Keyboard Viewer when pressed.

    I have been scouring the net trying to find an answer. I think system preferences have been changed somehow, inadvertently when I pressed a combination of keys.

    I would really like to get my shift button back. And the up arrow.

    This is absurd. There MUST be a simple answer. Please help!

    --ADD to this the down(volume) key. Gone.

    --AND the left-side alt/option key, and the right-side control key. All gone.
     

Share This Page