Shift+r doesnt work. Can't make a capital r without caps lock on

Discussion in 'Mac Basics and Help' started by jsook724, Dec 27, 2009.

  1. jsook724 macrumors regular

    Joined:
    Aug 2, 2008
    Location:
    CA
    #1
    For the past couple months,I've had to deal with shift+r not working . the only way i could get a capital r was with caps lock. and its gotten very annoying lately.

    i know its a software error because ive used 3 different keyboards and i get the same problem with all of them. What could be wrong? I have a PowerMacG5 on OS 10.5.8.

    thanks
     
  2. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #2
    You need to narrow down the problem further. Good to know that it's a software issue. Next, try seeing if the issue happens on a new user account.

    Go to System Preferences > Accounts. Turn on the Guest Account, and log in to it. While using the Guest account, check to see if Shift + R will work. If it does, you know the problem is specific to your user account. If it still doesn't work, you know it's a problem system-wide.

    In either case, this is often due to a bad preference file or something weird along those lines. Usually it can be fixed by simply trashing the bad file and restarting the computer. The problem here is there are sometimes HUNDREDS of preference files. By seeing if it's a system-wide issue, or just an issue with your account, this helps to further narrow down the possibilities.

    Your user preference files are located in your userfolder/Library/Preferences folder. The system-wide preference files are located in Macintosh HD/Library/Preferences. Don't go deleting anything without first knowing what exactly (and what files exactly) are causing the problem.
     
  3. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #3
    Just in case you need more info...

    You can easily spot the preference files, 'cause they're in a Preferences folder (yeah, really!) and they have the .plist suffix.

    The caution about deleting is a good one. Move a suspect file to the Desktop. Restart, or fire up the application associated with it. This creates a new plist set to defaults. If you still have the problem, keep looking.

    Sometimes this kind of thing can be caused by a conflict. Maybe something is set to use Shift-R as a shortcut. Not a good idea, but possible. Look in your Keyboard Shortcuts preference pane.
     

Share This Page