Should I buy DiskWarrior? LaCie external disk not mounting

Discussion in 'Mac Basics and Help' started by andybones78, Jun 7, 2012.

  1. andybones78 macrumors newbie

    Joined:
    Jun 7, 2012
    Location:
    Hong Kong
    #1
    Hi All,

    I'm new here so hope I'm doing things correctly!?

    I've had my 500GB LaCie LaCinema Rugged Drive for around 2 years and have never had a problem with it. I've used it with two different Macbook Pro's and also connected to my TV via the HDMI cable. Yesterday the drive just completely failed to mount on my desktop as normal, and I've tried it connected to my second Macbook Pro and there is the same result - no mount and the drive cannot be seen by the Disk Utility application in OS X Lion 10.7.4.

    I then tried connecting the drive to my TV in the normal way via the HDMI cable, and also via USB (as my TV supports this). The drive is powering up fine, and when connected to the TV I can see the menus and set-up screens, but all of the Music, Video and File Folder icons display ZERO files when you go into them via the menu. There should be around 250-300GB of data on the drive, so I'm guessing that the Directory has been somehow corrupted and that's why I can't see the files and the disk won't mount.

    I'm fairly confident that the drive is still relatively ok and that the data is not lost, just that I need to somehow rebuild the directory. It doesn't take long to gather that most people recommend DiskWarrior for Mac drive problems, so my main question is - has anyone used DiskWarrior for a similar problem, and did it work? I don't want to pay the $99USD for it if there's not much chance that it will help.

    If there is anyone out there who can definitively tell me that DiskWarrior will enable me to mount the drive and possibly repair the directory, that would be amazing. OR, if anyone out there has any other suggestions they would be very welcome!

    Many thanks :)
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Try booting from the install disc (or recovery partition if using Lion) and using its Disk Utility. If it can't see it either, then I doubt DiskWarrior can either. Once chance is that the actual drive is fine but the enclosure is kaput. You could try opening the enclosure and taking the drive out. Then use another enclosure if you have one or install the drive internally.
     

Share This Page