Should I update my 4S to 5.1?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by togu, Apr 17, 2012.

  1. togu macrumors newbie

    Joined:
    Apr 15, 2012
    #1
    I have iPhone 4S 5.0.1 but I messed up and did something on root and stash file while installing on previously jailbroken device (cydia was missing). Now I cannot properly boot my phone, read alot of threads on how to SSH in DFU mode but no luck. So kinda got stuck. So my question is should I update it to 5.1 and wait for the new jailbreak? I didn't save any SHSH Blobs since redsn0w won't let me (device unsupported), tinyumbrella won't work during in DFU mode. Do I have to have the SHSH Blobs saved in order to get 5.1 jailbroken?
    So any suggestion is welcome.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    1st you cannot use shsh blobs to restore an iphone 4S.
    You can save them but currently they cannot be used so even if you had 5.0.1 blobs for your 4S they are useless right now.
    2nd seems like your only option is to restore it to 5.1 and wait for the new JB.
    Good luck.
     
  3. togu thread starter macrumors newbie

    Joined:
    Apr 15, 2012
    #3
    But no matter how hard I try to save SHSH, those softwares won't let me dump it due unsupported device. tinyumbrella isn't working in DFU/Recovery mode. I have conflicting opinion on updating to 5.1. If I update it my baseband will be updated as well and at the time of the new JB release (redsn0w) may require old baseband and I will be doomed (sitting with new bb). In the other hand Apple may release their new 5.2 before the new JB is actually publically released and therefore itunes will not let me update to 5.1 cuz of the new ios 5.2
     
  4. Ray- macrumors regular

    Ray-

    Joined:
    Apr 18, 2012
    #4
    If your phone is at that point already, I'd say try flashing it completely instead of trying to SSH into it to fix it unless you reallllly know what you're doing.

    And you dont *have* to flash the phone to 5.1. When you update or restore your phone from iTunes, you're not stuck with whatever latest version iTunes grabs from its servers.

    You can try googling and then downloading a 5.0.1 ipsw and then in iTunes, shift+left click on the "Restore" button. A window will pop up that will let you browse to your ipsw file and restore with that. With any luck it will let you flash and fix your phone.
     
  5. Applejuiced, Apr 18, 2012
    Last edited: Apr 18, 2012

    Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Tinyumbrella works for the 4S.
    But it wont dump its current 5.0.1 shsh blobs, you can only get shsh blobs now for 5.1
    And like I told you even if you had shsh blobs you cannot do anything with them on a 4S.
    Also the new JB that will be released soon has nothing to do with the baseband. Basebands are only for unlocking.

    That is false.
    You can do that back with an iphone 3G on the 3.0 days.
    Now that simple process will not work.
    Shsh blobs come into play and even if you do have them they are useless right now for the 4S.
    Educate yourself before you give false advice to others.
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    Applejuiced is right (as usual..)

    BB has nothing to do with a jailbreak.
    And no you don't need the SHSH's to jailbreak either its only used to dowgrade, which currently is only possible on non A5 devices (IP4, IP3GS, etc)

    Unfortunate that you are stuck in this situation, only option seems to be to update to 5.1 and wait for the JB.
     
  7. Ray- macrumors regular

    Ray-

    Joined:
    Apr 18, 2012
    #7
    Thank you, I stand corrected.
     

Share This Page